Every CVE Search/ Get API key

CVE-2022-35653

Moodle LTI module reflected XSS risk

6.1 MediumFix available

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

4.84%Up 3.8 points since Jul 26, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Record
CVE-2022-35653
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Record
CVE-2022-35653
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-6256 No score

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Record
EUVD-2022-6256
Updated
2026-11-03
GitHub AdvisoriesGHSA-62wh-m4jr-233r 6.1

Moodle LTI module reflected XSS risk

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Record
GHSA-62wh-m4jr-233r
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-62wh-m4jr-233r 6.1

Moodle LTI module reflected XSS risk

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Record
GHSA-62wh-m4jr-233r
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2022-35653 6.1

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Record
UBUNTU-CVE-2022-35653
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVBIT-moodle-2022-35653 No score

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Record
BIT-moodle-2022-35653
Updated
2026-11-02
OSV No score

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Record
CVE-2022-35653
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
4.0 up to 4.0.2
4.0.2
moodle/moodle
Packagist
3.11 up to 3.11.8
3.11.8
moodle/moodle
Packagist
3.9 up to 3.9.15
3.9.15
moodle
Bitnami
3.9.0 up to 3.9.15, 3.11.0 up to 3.11.8, 4.0.0 up to 4.0.1, 4.0.1 up to 4.0.2
3.9.153.11.84.0.14.0.2
moodle/moodle
Packagist
4.0 up to 4.0.2, plus listed versions
v4.0.0v4.0.0-betav4.0.0-rc1v4.0.0-rc2v4.0.0-rc3v4.0.0-rc4v4.0.1
4.0.2
moodle/moodle
Packagist
3.11 up to 3.11.8, plus listed versions
v3.11.0v3.11.0-betav3.11.0-rc1v3.11.0-rc2v3.11.1
Show 6 moreShow less
v3.11.2v3.11.3v3.11.4v3.11.5v3.11.6v3.11.7
3.11.8
moodle/moodle
Packagist
3.9 up to 3.9.15, plus listed versions
v3.9.0v3.9.0-betav3.9.0-rc1v3.9.0-rc2v3.9.0-rc3
Show 14 moreShow less
v3.9.1v3.9.10v3.9.11v3.9.12v3.9.13v3.9.14v3.9.2v3.9.3v3.9.4v3.9.5v3.9.6v3.9.7v3.9.8v3.9.9
3.9.15
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
NucleiMoodle LTI module Reflected - Cross-Site Scripting

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, Nuclei, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-35653 is a medium vulnerability (CVSS 6.1) in Moodle, published July 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.84%, the 92nd percentile. Fixed in moodle/moodle 4.0.2.

References

Show 7 moreShow less
MoveEnter Open