CVE-2022-35909
Incorrect Access Control and Cross Site Scripting in Jellyfin
In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality.
- Record
CVE-2022-35909- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
CVE List No score
In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality.
- Record
CVE-2022-35909- Updated
- 2026-11-02
EUVDEUVD-2022-6613 No score
In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality.
- Record
EUVD-2022-6613- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qwp3-5fw3-5wgv
8.8
Incorrect Access Control and Cross Site Scripting in Jellyfin
In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality. This lack of access control can be leveraged to performe a cross site scripting attack.
- Record
GHSA-qwp3-5fw3-5wgv- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-qwp3-5fw3-5wgv
8.8
Incorrect Access Control and Cross Site Scripting in Jellyfin
In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality. This lack of access control can be leveraged to performe a cross site scripting attack.
- Record
GHSA-qwp3-5fw3-5wgv- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
In Jellyfin before 10.8, the /users endpoint has incorrect access control for admin functionality.
- Record
CVE-2022-35909- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
Jellyfin.CommonNuGet |
before 10.8.0 | 10.8.0 |
Jellyfin.CommonNuGet |
before 10.8.0, plus listed versions 10.0.110.1.010.2.010.2.0.110.3.0 Show 36 moreShow less10.3.0-rc110.3.510.3.610.3.710.4.010.4.0-pre110.4.0-pre210.4.110.4.210.4.310.5.010.5.0-pre110.5.210.5.310.5.410.5.510.6.010.7.010.7.0-rc110.7.0-rc210.7.0-rc310.7.0-rc410.7.110.7.210.7.310.7.410.7.510.7.610.7.710.8.0-alpha210.8.0-alpha310.8.0-alpha410.8.0-alpha510.8.0-beta110.8.0-beta210.8.0-beta3 |
10.8.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-35909 is a high vulnerability (CVSS 8.8) in Jellyfin, published August 19, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in Jellyfin.Common 10.8.0.
References
docs.google.com/document/d/1cBXQrokCvWxKET4BKi3ZLtVp5gst6-MrGPgMKpfXw8Y/edit
github.com/jellyfin/jellyfin/pull/7569/files
medium.com/stolabs/cve-2022-35909-cve-2022-35910-incorrect-access-control-and-xss-stored-to-jellyfin-967359c91058
nvd.nist.gov/vuln/detail/CVE-2022-35909
github.com/advisories/GHSA-qwp3-5fw3-5wgv
github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35909.json
github.com/jellyfin/jellyfin