CVE-2022-35912
Grails framework Remote Code Execution via Data Binding
In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.
- Record
CVE-2022-35912- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
CVE List No score
In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.
- Record
CVE-2022-35912- Updated
- 2026-11-02
EUVDEUVD-2022-6263 No score
In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.
- Record
EUVD-2022-6263- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6rh6-x8ww-9h97
9.8
Grails framework Remote Code Execution via Data Binding
Impact
A vulnerability has been discovered in the Grails data-binding logic which allows for Remote Code Execution in a Grails application. This exploit requires the application to be running on Java 8, either deployed as a WAR to a servlet container, or an executable JAR.
Patches
Grails framework versions 5.2.1, 5.1.9, 4.1.1, and 3.3.15
References
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-35912 https://grails.org/blog/2022-07-18-rce-vulnerability.html
For more information
If you have any questions or comments about this advisory:
- https://grails.org/blog/2022-07-18-rce-vulnerability.html
- https://github.com/grails/grails-core/issues/12626
- Email us at [email protected]
Credit
This vulnerability was discovered by meizjm3i and codeplutos of AntGroup FG Security Lab
- Record
GHSA-6rh6-x8ww-9h97- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-6rh6-x8ww-9h97
9.8
Grails framework Remote Code Execution via Data Binding
Impact
A vulnerability has been discovered in the Grails data-binding logic which allows for Remote Code Execution in a Grails application. This exploit requires the application to be running on Java 8, either deployed as a WAR to a servlet container, or an executable JAR.
Patches
Grails framework versions 5.2.1, 5.1.9, 4.1.1, and 3.3.15
References
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-35912 https://grails.org/blog/2022-07-18-rce-vulnerability.html
For more information
If you have any questions or comments about this advisory:
- https://grails.org/blog/2022-07-18-rce-vulnerability.html
- https://github.com/grails/grails-core/issues/12626
- Email us at [email protected]
Credit
This vulnerability was discovered by meizjm3i and codeplutos of AntGroup FG Security Lab
- Record
GHSA-6rh6-x8ww-9h97- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.
- Record
CVE-2022-35912- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.grails:grails-databindingMaven |
3.3.10 up to 3.3.15 | 3.3.15 |
org.grails:grails-databindingMaven |
4.0.0 up to 4.1.1 | 4.1.1 |
org.grails:grails-databindingMaven |
5.0.0 up to 5.1.9 | 5.1.9 |
org.grails:grails-databindingMaven |
5.2.0 to 5.2.0 | 5.2.1 |
org.grails:grails-databindingMaven |
3.3.10 up to 3.3.15, plus listed versions 3.3.133.3.14 |
3.3.15 |
org.grails:grails-databindingMaven |
4.0.0 up to 4.1.1, plus listed versions 4.0.14.0.104.0.114.0.124.0.13 Show 8 moreShow less4.0.54.0.64.0.74.0.84.0.94.1.04.1.0.M34.1.0.M4 |
4.1.1 |
org.grails:grails-databindingMaven |
5.0.0 up to 5.1.9, plus listed versions 5.0.15.0.25.0.35.1.05.1.1 Show 7 moreShow less5.1.25.1.35.1.45.1.55.1.65.1.75.1.8 |
5.1.9 |
org.grails:grails-databindingMaven |
5.2.0 up to 5.2.1 | 5.2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-35912 is a critical vulnerability (CVSS 9.8) in Grails, published July 19, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.34%, the 83rd percentile. Fixed in org.grails:grails-databinding 3.3.15.
References
github.com/grails/grails-core/security/advisories/GHSA-6rh6-x8ww-9h97
grails.org/blog/2022-07-18-rce-vulnerability.html
github.com/grails/grails-core/issues/12626
openwall.com/lists/oss-security/2022/07/20/4
nvd.nist.gov/vuln/detail/CVE-2022-35912
github.com/advisories/GHSA-6rh6-x8ww-9h97
github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35912.json
github.com/grails/grails-core