CVE-2022-36023
Remote denial of service in Hyperledger Fabric Gateway
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.0
Remote denial of service in Hyperledger Fabric Gateway
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
- Record
CVE-2022-36023- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2022-7152
7.0
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
- Record
EUVD-2022-7152- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-qj6r-fhrc-jj5r
7.0
Remote denial of service in Hyperledger Fabric Gateway
Impact
If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. This fix checks for the malformed gateway request and returns an error to the gateway client.
Patches
Fixed in v2.4.6.
Workarounds
None, users must upgrade to v2.4.6.
References
https://github.com/hyperledger/fabric/releases/tag/v2.4.6
For more information
If you have any questions or comments about this advisory:
- Open an issue in Fabric
Credits
Thank you to Haosheng Wang of OPPO ZIWU Security Lab for this disclosure.
- Record
GHSA-qj6r-fhrc-jj5r- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
NVD
7.0
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
- Record
CVE-2022-36023- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.0
Remote denial of service in Hyperledger Fabric Gateway
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
- Record
CVE-2022-36023- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-qj6r-fhrc-jj5r
7.0
Remote denial of service in Hyperledger Fabric Gateway
Impact
If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. This fix checks for the malformed gateway request and returns an error to the gateway client.
Patches
Fixed in v2.4.6.
Workarounds
None, users must upgrade to v2.4.6.
References
https://github.com/hyperledger/fabric/releases/tag/v2.4.6
For more information
If you have any questions or comments about this advisory:
- Open an issue in Fabric
Credits
Thank you to Haosheng Wang of OPPO ZIWU Security Lab for this disclosure.
- Record
GHSA-qj6r-fhrc-jj5r- CVSS 3.1
- 7.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVBIT-hyperledger-fabric-orderer-2022-36023 No score
Remote denial of service in Hyperledger Fabric Gateway
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
- Record
BIT-hyperledger-fabric-orderer-2022-36023- Updated
- 2026-11-02
OSVBIT-hyperledger-fabric-peer-2022-36023 No score
Remote denial of service in Hyperledger Fabric Gateway
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
- Record
BIT-hyperledger-fabric-peer-2022-36023- Updated
- 2026-11-02
OSVBIT-hyperledger-fabric-tools-2022-36023 No score
Remote denial of service in Hyperledger Fabric Gateway
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
- Record
BIT-hyperledger-fabric-tools-2022-36023- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/hyperledger/fabricGo |
2.4.0 up to 2.4.6 | 2.4.6 |
hyperledger-fabric-ordererBitnami |
before 2.4.6 | 2.4.6 |
hyperledger-fabric-peerBitnami |
before 2.4.6 | 2.4.6 |
hyperledger-fabric-toolsBitnami |
before 2.4.6 | 2.4.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-36023 is a high vulnerability (CVSS 7.0) in Hyperledger Fabric, published August 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.16%, the 67th percentile. Fixed in github.com/hyperledger/fabric 2.4.6.
References
github.com/hyperledger/fabric/security/advisories/GHSA-qj6r-fhrc-jj5r
github.com/hyperledger/fabric/releases/tag/v2.4.6
github.com/hyperledger/fabric/pull/3572
github.com/hyperledger/fabric/pull/3576
github.com/hyperledger/fabric/pull/3577
nvd.nist.gov/vuln/detail/CVE-2022-36023
github.com/advisories/GHSA-qj6r-fhrc-jj5r
github.com/CVEProject/cvelistV5/tree/main/cves/2022/36xxx/CVE-2022-36023.json
github.com/hyperledger/fabric