Every CVE Search/ Get API key

CVE-2022-36110

Netmaker vulnerable to Insufficient Granularity of Access Control

8.8 HighFix available

Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.90%Unchanged since Sep 10, 2022
90%50%10%1%

What each source reports

CVE List Score used 8.8

Netmaker vulnerable to Insufficient Granularity of Access Control

Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

Record
CVE-2022-36110
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1220, CWE-285
Updated
2026-11-02
EUVDEUVD-2022-6822 8.8

Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

Record
EUVD-2022-6822
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-ggf6-638m-vqmg 8.8

Netmaker vulnerable to Insufficient Granularity of Access Control

Impact

Improper Authorization functions leads to non-privileged users running privileged API calls. If you have added users to your Netmaker platform who whould not have admin privileges, they could use their auth token to run admin-level functions via the API.

In addition, differing response codes based on function calls allowed non-users to potentially brute force the determination of names of networks on the system.

Patches

This problem has been patched in v0.15.1. To apply:

  1. docker-compose down
  2. docker pull gravitl/netmaker:v0.15.1
  3. docker-compose up -d

For more information

If you have any questions or comments about this advisory:

Email us at [email protected] This vulnerability was brought to our attention by @tweidinger

Record
GHSA-ggf6-638m-vqmg
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-285, CWE-1220
Updated
2026-11-02
NVD 8.8

Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

Record
CVE-2022-36110
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-285, CWE-1220
Updated
2026-11-02
OSV 8.8

Netmaker vulnerable to Insufficient Granularity of Access Control

Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

Record
CVE-2022-36110
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1220, CWE-285
Updated
2026-11-02
OSVGHSA-ggf6-638m-vqmg 8.8

Netmaker vulnerable to Insufficient Granularity of Access Control

Impact

Improper Authorization functions leads to non-privileged users running privileged API calls. If you have added users to your Netmaker platform who whould not have admin privileges, they could use their auth token to run admin-level functions via the API.

In addition, differing response codes based on function calls allowed non-users to potentially brute force the determination of names of networks on the system.

Patches

This problem has been patched in v0.15.1. To apply:

  1. docker-compose down
  2. docker pull gravitl/netmaker:v0.15.1
  3. docker-compose up -d

For more information

If you have any questions or comments about this advisory:

Email us at [email protected] This vulnerability was brought to our attention by @tweidinger

Record
GHSA-ggf6-638m-vqmg
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1220, CWE-285
Updated
2026-11-02
OSVGO-2022-0986 No score

Netmaker vulnerable to Insufficient Granularity of Access Control in github.com/gravitl/netmaker

Netmaker vulnerable to Insufficient Granularity of Access Control in github.com/gravitl/netmaker

Record
GO-2022-0986
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/gravitl/netmaker
Go
before 0.15.1
0.15.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-36110 is a high vulnerability (CVSS 8.8) in Gravitl Netmaker, published September 9, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.90%, the 59th percentile. Fixed in github.com/gravitl/netmaker 0.15.1.

References

MoveEnter Open