CVE-2022-37248
Craft CMS Cross site Scripting vulnerability
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
- Record
CVE-2022-37248- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
- Record
CVE-2022-37248- Updated
- 2026-11-02
EUVDEUVD-2022-6971 No score
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
- Record
EUVD-2022-6971- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wxvf-839f-jqmh
5.4
Craft CMS Cross site Scripting vulnerability
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
- Record
GHSA-wxvf-839f-jqmh- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-wxvf-839f-jqmh
5.4
Craft CMS Cross site Scripting vulnerability
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
- Record
GHSA-wxvf-839f-jqmh- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
- Record
CVE-2022-37248- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
craftcms/cmsPackagist |
4.0.0-RC1 up to 4.2.1 | 4.2.1 |
craftcms/cmsPackagist |
4.0.0-RC1 up to 4.2.1, plus listed versions 4.0.04.0.0-RC24.0.0-RC34.0.0.14.0.1 Show 18 moreShow less4.0.24.0.34.0.44.0.54.0.5.14.0.5.24.0.64.1.04.1.0.14.1.0.24.1.14.1.24.1.34.1.44.1.4.14.2.04.2.0.14.2.0.2 |
4.2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-37248 is a medium vulnerability (CVSS 5.4) in Craftcms Craft Cms, published September 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.66%, the 51st percentile. Fixed in craftcms/cms 4.2.1.
References
github.com/craftcms/cms/commit/cedeba0609e4b173cd584dae7f33c5f713f19627
labs.integrity.pt/advisories/cve-2022-37248
nvd.nist.gov/vuln/detail/CVE-2022-37248
github.com/craftcms/cms/blob/develop/CHANGELOG.md
github.com/craftcms/cms/blob/3.7.55.1/src/helpers/Cp.php
github.com/craftcms/cms/blob/4.0.0-RC1/src/helpers/Cp.php
github.com/advisories/GHSA-wxvf-839f-jqmh
github.com/CVEProject/cvelistV5/tree/main/cves/2022/37xxx/CVE-2022-37248.json
github.com/craftcms/cms