CVE-2022-37781
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46...
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
- Record
CVE-2022-37781- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
- Record
CVE-2022-37781- Updated
- 2026-11-02
EUVDEUVD-2022-40391 No score
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
- Record
EUVD-2022-40391- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fq49-9879-g3f8
7.8
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46...
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
- Record
GHSA-fq49-9879-g3f8- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-37781
7.8
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
- Record
ALPINE-CVE-2022-37781- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-37781
7.8
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
- Record
UBUNTU-CVE-2022-37781- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
- Record
CVE-2022-37781- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-37781 No score
fdkaac v1.0.3 was discovered to contain a heap buffer overflow via __interceptor_memcpy.part.46 at /sanitizer_common/sanitizer_common_interceptors.inc.
- Record
DEBIAN-CVE-2022-37781- Updated
- 2026-11-03
OSVUSN-7660-1 No score
fdkaac vulnerabilities
It was discovered that fdkaac did not correctly handle certain input. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2022-36148)
It was discovered that fdkaac did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2022-37781, CVE-2023-34823, CVE-2023-34824)
- Record
USN-7660-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fdkaacAlpine:v3.16 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacAlpine:v3.17 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacAlpine:v3.18 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacAlpine:v3.19 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacAlpine:v3.20 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacAlpine:v3.21 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacAlpine:v3.22 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacAlpine:v3.23 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacAlpine:v3.24 |
before 1.0.3-r0 | 1.0.3-r0 |
fdkaacDebian:12 |
All versions, plus listed versions 0.6.2-10.6.3-11.0.0-11.0.6-0.1 |
None known |
Show 15 moreShow less
| Package | Affected | Fixed |
|---|---|---|
fdkaacDebian:13 |
before 1.0.6-0.1, plus listed versions 0.6.2-10.6.3-11.0.0-1 |
1.0.6-0.1 |
fdkaacDebian:14 |
before 1.0.6-0.1, plus listed versions 0.6.2-10.6.3-11.0.0-1 |
1.0.6-0.1 |
fdkaacUbuntu:Pro:16.04:LTS |
before 0.6.2-1ubuntu0.1~esm1, plus listed versions 0.6.2-1 |
0.6.2-1ubuntu0.1~esm1 |
fdkaacUbuntu:Pro:18.04:LTS |
before 0.6.3-1ubuntu0.18.04.1~esm1, plus listed versions 0.6.3-1 |
0.6.3-1ubuntu0.18.04.1~esm1 |
fdkaacUbuntu:Pro:20.04:LTS |
before 0.6.3-1ubuntu0.20.04.1~esm1, plus listed versions 0.6.3-1 |
0.6.3-1ubuntu0.20.04.1~esm1 |
fdkaacUbuntu:Pro:22.04:LTS |
before 1.0.0-1ubuntu0.22.04.1~esm1, plus listed versions 1.0.0-1build1 |
1.0.0-1ubuntu0.22.04.1~esm1 |
fdkaacUbuntu:Pro:24.04:LTS |
before 1.0.0-1ubuntu0.24.04.1~esm1, plus listed versions 1.0.0-1build1 |
1.0.0-1ubuntu0.24.04.1~esm1 |
fdkaacUbuntu:25.10 |
All versions, plus listed versions 1.0.0-1build1 |
None known |
fdkaacUbuntu:26.10 |
All versions, plus listed versions 1.0.0-1build11.0.6-0.1build1 |
None known |
fdkaacUbuntu:26.04:LTS |
All versions, plus listed versions 1.0.0-1build1 |
None known |
fdkaacUbuntu:Pro:16.04:LTS From an advisory covering 4 CVEs |
before 0.6.2-1ubuntu0.1~esm1, plus listed versions 0.6.2-1 |
0.6.2-1ubuntu0.1~esm1 |
fdkaacUbuntu:Pro:18.04:LTS From an advisory covering 4 CVEs |
before 0.6.3-1ubuntu0.18.04.1~esm1, plus listed versions 0.6.3-1 |
0.6.3-1ubuntu0.18.04.1~esm1 |
fdkaacUbuntu:Pro:20.04:LTS From an advisory covering 4 CVEs |
before 0.6.3-1ubuntu0.20.04.1~esm1, plus listed versions 0.6.3-1 |
0.6.3-1ubuntu0.20.04.1~esm1 |
fdkaacUbuntu:Pro:22.04:LTS From an advisory covering 4 CVEs |
before 1.0.0-1ubuntu0.22.04.1~esm1, plus listed versions 1.0.0-1build1 |
1.0.0-1ubuntu0.22.04.1~esm1 |
fdkaacUbuntu:Pro:24.04:LTS From an advisory covering 4 CVEs |
before 1.0.0-1ubuntu0.24.04.1~esm1, plus listed versions 1.0.0-1build1 |
1.0.0-1ubuntu0.24.04.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-37781 is a high vulnerability (CVSS 7.8) in Fdkaac Project Fdkaac, published August 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 29th percentile. Fixed in fdkaac 1.0.3-r0.