CVE-2022-38073
WordPress Awesome Support plugin <= 6.0.7 - Multiple Authenticated Persistent XSS (Additional Interested Parties)
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.4
WordPress Awesome Support plugin <= 6.0.7 - Multiple Authenticated Persistent XSS (Additional Interested Parties)
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
- Record
CVE-2022-38073- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-6922
5.4
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
- Record
EUVD-2022-6922- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-qrqm-574x-q7f2
5.4
Awesome Support vulnerable to persistent cross-site scripting
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
- Record
GHSA-qrqm-574x-q7f2- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.4
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
- Record
CVE-2022-38073- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-qrqm-574x-q7f2
5.4
Awesome Support vulnerable to persistent cross-site scripting
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
- Record
GHSA-qrqm-574x-q7f2- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
awesome-support/awesome-supportPackagist |
through 6.0.7 | 6.0.8 |
awesome-support/awesome-supportPackagist |
before 6.0.8, plus listed versions 3.0.03.0.0-beta-13.0.0-beta-23.0.13.1.0 Show 45 moreShow less3.1.13.1.103.1.113.1.123.1.23.1.33.1.53.1.63.1.73.1.83.1.93.2.03.2.13.2.23.2.33.2.43.2.53.2.63.2.83.2.93.3.03.3.13.3.23.3.33.3.43.3.4_RC013.3.4_RC023.3.4_RC033.3.4_RC053.4.0_RC013.6.0_RC013.6.0_RC023.6.0_RC043.6.0_RC054.0.04.0.0_RC014.0.0_RC024.0.0_RC034.0.0_RC044.0.0_RC054.0.0_RC064.0.0_RC074.0.0_RC084.0.0_RC094.0.0_RC10 |
6.0.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-38073 is a medium vulnerability (CVSS 5.4) in Getawesomesupport Awesome Support, published September 21, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.58%, the 48th percentile. Fixed in awesome-support/awesome-support 6.0.8.
References
wordpress.org/plugins/awesome-support
patchstack.com/database/vulnerability/awesome-support/wordpress-awesome-support-plugin-6-0-7-multiple-authenticated-stored-cross-site-scripting-xss-vulnerabilities
nvd.nist.gov/vuln/detail/CVE-2022-38073
github.com/Awesome-Support/Awesome-Support/commit/85f460be88b81fbdd9a990f474a1252297902faf
github.com/Awesome-Support/Awesome-Support/commit/b2e831d7f831a3869cfd83eb79a398a5b5c0ec63
github.com/advisories/GHSA-qrqm-574x-q7f2
github.com/Awesome-Support/Awesome-Support
Left out here: 55 versions. The JSON record has them.