Every CVE Search/ Get API key

CVE-2022-39047

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack...

8.8 HighFix available

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.31%Up 0.4 points since Aug 31, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.

Record
CVE-2022-39047
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.

Record
CVE-2022-39047
Updated
2026-11-02
EUVDEUVD-2022-41593 No score

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.

Record
EUVD-2022-41593
Updated
2026-11-03
GitHub AdvisoriesGHSA-v44g-gwm6-58cw 8.8

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack...

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.

Record
GHSA-v44g-gwm6-58cw
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
OSVDEBIAN-CVE-2022-39047 8.8

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.

Record
DEBIAN-CVE-2022-39047
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-39047 8.8

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.

Record
UBUNTU-CVE-2022-39047
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV No score

Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.

Record
CVE-2022-39047
Updated
2026-11-02
OSVMGASA-2022-0293 No score

Updated freeciv packages fix security vulnerability

Advisory text to describe the update. Wrap lines at ~75 chars. Modpack Installer buffer overflow. (CVE-2022-39047)

Record
MGASA-2022-0293
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
freeciv
Debian:12
before 3.0.3-1
3.0.3-1
freeciv
Debian:13
before 3.0.3-1
3.0.3-1
freeciv
Debian:14
before 3.0.3-1
3.0.3-1
freeciv
Mageia:8
before 2.6.7-1.mga8
2.6.7-1.mga8
freeciv
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.5.1-12.5.2-12.5.3-12.5.3-1ubuntu0.1~esm1
None known
freeciv
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
2.5.9-12.5.10-12.5.10-1ubuntu0.1~esm1
None known
freeciv
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
2.6.0-32.6.0-42.6.1-12.6.2-12.6.2-1ubuntu0.1~esm1
None known
freeciv
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
2.6.3-12.6.5-12.6.6-12.6.6-1ubuntu0.1~esm1
None known
freeciv
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
3.0.8-13.0.8-23.0.8-2build13.1.0+ds-1build33.1.0+ds-1build43.1.0+ds-1build53.1.0+ds-1ubuntu0.1~esm1
None known
freeciv
Ubuntu:25.10
All versions, plus listed versions
3.1.4+ds-23.2.0+ds-1
None known
freeciv
Ubuntu:26.10
All versions, plus listed versions
3.2.4+ds-13.2.5+ds-13.2.6+ds-1
None known
freeciv
Ubuntu:26.04:LTS
All versions, plus listed versions
3.2.0+ds-13.2.1+ds-13.2.1+ds-1build13.2.2+ds-13.2.4+ds-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-39047 is a high vulnerability (CVSS 8.8) in Freeciv, published August 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.31%, the 70th percentile. Fixed in freeciv 3.0.3-1.

References

Show 8 moreShow less
MoveEnter Open