CVE-2022-39832
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function...
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_string in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_string in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
CVE-2022-39832- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_string in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
CVE-2022-39832- Updated
- 2026-11-02
EUVDEUVD-2022-42277 No score
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_string in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
EUVD-2022-42277- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-93gw-qjv3-mc4m
7.8
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function...
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_string in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
GHSA-93gw-qjv3-mc4m- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
7.8
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_string in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
CVE-2022-39832- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-39832
7.8
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_string in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
DEBIAN-CVE-2022-39832- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-39832
7.8
An issue was discovered in PSPP 1.6.2. There is a heap-based buffer overflow at the function read_string in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
UBUNTU-CVE-2022-39832- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
psppDebian:12 |
before 1.6.2-2 | 1.6.2-2 |
psppDebian:13 |
before 1.6.2-2 | 1.6.2-2 |
psppDebian:14 |
before 1.6.2-2 | 1.6.2-2 |
psppUbuntu:16.04:LTS |
All versions, plus listed versions 0.8.5-40.8.5-4build10.8.5-50.8.5-5build1 |
None known |
psppUbuntu:18.04:LTS |
All versions, plus listed versions 1.0.1-1 |
None known |
psppUbuntu:22.04:LTS |
All versions, plus listed versions 1.4.1-11.4.1-1build1 |
None known |
psppUbuntu:24.04:LTS |
All versions, plus listed versions 1.6.2-22.0.0-32.0.0-3build12.0.0-3build2 |
None known |
psppUbuntu:25.10 |
All versions, plus listed versions 2.0.1-1build12.0.1-1build2 |
None known |
psppUbuntu:26.10 |
All versions, plus listed versions 2.0.1-1build3 |
None known |
psppUbuntu:26.04:LTS |
All versions, plus listed versions 2.0.1-1build22.0.1-1build3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-39832 is a high vulnerability (CVSS 7.8) in Gnu Pspp, published September 5, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.51%, the 43rd percentile. Fixed in pspp 1.6.2-2.
References
savannah.gnu.org/bugs/index.php?63000
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VQKWIVW5WJ5ZQNNQFRKTRKD7J3LRLUYW
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OECANCPD4WSSBJLSC3EE472M5DXRTIS4
nvd.nist.gov/vuln/detail/CVE-2022-39832
lists.fedoraproject.org/archives/list/[email protected]/message/VQKWIVW5WJ5ZQNNQFRKTRKD7J3LRLUYW
lists.fedoraproject.org/archives/list/[email protected]/message/OECANCPD4WSSBJLSC3EE472M5DXRTIS4