Every CVE Search/ Get API key

CVE-2022-39986

RaspAP Command Injection vulnerability

9.8 CriticalPublic exploitFix available

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

99.1%Up 99.0 points since Aug 2, 2023
90%50%10%1%

What each source reports

NVD Score used 9.8

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Record
CVE-2022-39986
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
CVE List No score

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Record
CVE-2022-39986
Updated
2026-11-02
EUVDEUVD-2023-2233 No score

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Record
EUVD-2023-2233
Updated
2026-11-03
GitHub AdvisoriesGHSA-7c28-wg7r-pg6f 9.8

RaspAP Command Injection vulnerability

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Record
GHSA-7c28-wg7r-pg6f
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSVGHSA-7c28-wg7r-pg6f 9.8

RaspAP Command Injection vulnerability

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Record
GHSA-7c28-wg7r-pg6f
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSV No score

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Record
CVE-2022-39986
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
billz/raspap-webgui
Packagist
2.8.0 up to 2.8.8
2.8.8
billz/raspap-webgui
Packagist
2.8.0 up to 2.8.8, plus listed versions
2.8.12.8.22.8.32.8.42.8.52.8.62.8.7
2.8.8

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-39986 is a critical vulnerability (CVSS 9.8) in Raspap, published August 1, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 99.1%, the 99th percentile. Fixed in billz/raspap-webgui 2.8.8.

References

Show 4 moreShow less
MoveEnter Open