Every CVE Search/ Get API key

CVE-2022-40084

OpenCRX vulnerable to password enumeration via error messages in password reset

5.3 MediumFix available

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.78%Down 0.1 points since Oct 22, 2022
90%50%10%1%

What each source reports

NVD Score used 5.3

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

Record
CVE-2022-40084
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-203
Updated
2026-11-02
CVE List 5.3

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

Record
CVE-2022-40084
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-203
Updated
2026-11-02
EUVDEUVD-2022-7113 5.3

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

Record
EUVD-2022-7113
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-j5v3-363p-g843 5.3

OpenCRX vulnerable to password enumeration via error messages in password reset

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

Record
GHSA-j5v3-363p-g843
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-203
Updated
2026-11-02
OSV 5.3

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

Record
CVE-2022-40084
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVGHSA-j5v3-363p-g843 5.3

OpenCRX vulnerable to password enumeration via error messages in password reset

OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the difference in error messages received during a password reset which could enable an attacker to determine if a username, email or ID is valid.

Record
GHSA-j5v3-363p-g843
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-203
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.opencrx:opencrx-client
Maven
before 5.2.2
5.2.2
org.opencrx:opencrx-client
Maven
before 5.2.2, plus listed versions
4.3-alpha-14.3-alpha-104.3-alpha-114.3-alpha-24.3-alpha-3
Show 12 moreShow less
4.3-alpha-44.3-alpha-54.3-alpha-64.3-alpha-74.3-alpha-84.3-alpha-94.3.05.0.05.0.15.1.05.2.05.2.1
5.2.2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-40084 is a medium vulnerability (CVSS 5.3) in Opencrx, published October 20, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.78%, the 56th percentile. Fixed in org.opencrx:opencrx-client 5.2.2.

References

MoveEnter Open