CVE-2022-40313
Moodle Stored Cross-site Scripting and page denial of service
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
NVD Score used
7.1
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
- Record
CVE-2022-40313- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List
7.1
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
- Record
CVE-2022-40313- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-7119
7.1
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
- Record
EUVD-2022-7119- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-jqgr-gh62-jf53
7.1
Moodle Stored Cross-site Scripting and page denial of service
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an Cross-site Scripting risk or a page failing to load.
- Record
GHSA-jqgr-gh62-jf53- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
7.1
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
- Record
CVE-2022-40313- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
OSVGHSA-jqgr-gh62-jf53
7.1
Moodle Stored Cross-site Scripting and page denial of service
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an Cross-site Scripting risk or a page failing to load.
- Record
GHSA-jqgr-gh62-jf53- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-40313
7.1
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
- Record
UBUNTU-CVE-2022-40313- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
OSVBIT-moodle-2022-40313 No score
Recursive rendering of Mustache template helpers containing user input could, in some cases, result in an XSS risk or a page failing to load.
- Record
BIT-moodle-2022-40313- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
3.9 up to 3.9.17 | 3.9.17 |
moodle/moodlePackagist |
3.11 up to 3.11.10 | 3.11.10 |
moodle/moodlePackagist |
4.0 up to 4.0.4 | 4.0.4 |
moodleBitnami |
3.9.0 up to 3.9.17, 3.11.0 up to 3.11.10, 4.0.0 up to 4.0.4 | 3.9.173.11.104.0.4 |
moodle/moodlePackagist |
3.9 up to 3.9.17, plus listed versions v3.9.0v3.9.0-betav3.9.0-rc1v3.9.0-rc2v3.9.0-rc3 Show 16 moreShow lessv3.9.1v3.9.10v3.9.11v3.9.12v3.9.13v3.9.14v3.9.15v3.9.16v3.9.2v3.9.3v3.9.4v3.9.5v3.9.6v3.9.7v3.9.8v3.9.9 |
3.9.17 |
moodle/moodlePackagist |
3.11 up to 3.11.10, plus listed versions v3.11.0v3.11.0-betav3.11.0-rc1v3.11.0-rc2v3.11.1 Show 8 moreShow lessv3.11.2v3.11.3v3.11.4v3.11.5v3.11.6v3.11.7v3.11.8v3.11.9 |
3.11.10 |
moodle/moodlePackagist |
4.0 up to 4.0.4, plus listed versions v4.0.0v4.0.0-betav4.0.0-rc1v4.0.0-rc2v4.0.0-rc3 Show 4 moreShow lessv4.0.0-rc4v4.0.1v4.0.2v4.0.3 |
4.0.4 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-40313 is a high vulnerability (CVSS 7.1) in Moodle, published September 30, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.72%, the 53rd percentile. Fixed in moodle/moodle 3.9.17.
References
bugzilla.redhat.com/show_bug.cgi?id=2128146
moodle.org/mod/forum/discuss.php?d=438392
nvd.nist.gov/vuln/detail/CVE-2022-40313
github.com/advisories/GHSA-jqgr-gh62-jf53
github.com/CVEProject/cvelistV5/tree/main/cves/2022/40xxx/CVE-2022-40313.json
github.com/moodle/moodle
ubuntu.com/security/CVE-2022-40313
cve.org/CVERecord?id=CVE-2022-40313