CVE-2022-40314
Moodle remote code execution
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
- Record
CVE-2022-40314- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
CVE List
9.8
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
- Record
CVE-2022-40314- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
EUVDEUVD-2022-6989
9.8
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
- Record
EUVD-2022-6989- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-2hmm-q272-xmhf
9.8
Moodle remote code execution
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
- Record
GHSA-2hmm-q272-xmhf- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
9.8
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
- Record
CVE-2022-40314- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-2hmm-q272-xmhf
9.8
Moodle remote code execution
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
- Record
GHSA-2hmm-q272-xmhf- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-40314
9.8
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
- Record
UBUNTU-CVE-2022-40314- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-moodle-2022-40314 No score
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
- Record
BIT-moodle-2022-40314- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 3.9.17 | 3.9.17 |
moodle/moodlePackagist |
3.11 up to 3.11.10 | 3.11.10 |
moodle/moodlePackagist |
4.0 up to 4.0.4 | 4.0.4 |
moodleBitnami |
3.9.0 up to 3.9.17, 3.11.0 up to 3.11.10, 4.0.0 up to 4.0.4 | 3.9.173.11.104.0.4 |
moodle/moodlePackagist |
before 3.9.17, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 45 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1 |
3.9.17 |
moodle/moodlePackagist |
3.11 up to 3.11.10, plus listed versions v3.11.0v3.11.0-betav3.11.0-rc1v3.11.0-rc2v3.11.1 Show 8 moreShow lessv3.11.2v3.11.3v3.11.4v3.11.5v3.11.6v3.11.7v3.11.8v3.11.9 |
3.11.10 |
moodle/moodlePackagist |
4.0 up to 4.0.4, plus listed versions v4.0.0v4.0.0-betav4.0.0-rc1v4.0.0-rc2v4.0.0-rc3 Show 4 moreShow lessv4.0.0-rc4v4.0.1v4.0.2v4.0.3 |
4.0.4 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-40314 is a critical vulnerability (CVSS 9.8) in Moodle, published September 30, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.10%, the 81st percentile. Fixed in moodle/moodle 3.9.17.
References
bugzilla.redhat.com/show_bug.cgi?id=2128147
moodle.org/mod/forum/discuss.php?d=438393
nvd.nist.gov/vuln/detail/CVE-2022-40314
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-75405
github.com/advisories/GHSA-2hmm-q272-xmhf
github.com/CVEProject/cvelistV5/tree/main/cves/2022/40xxx/CVE-2022-40314.json
github.com/moodle/moodle
ubuntu.com/security/CVE-2022-40314
cve.org/CVERecord?id=CVE-2022-40314
Left out here: 214 versions. The JSON record has them.