Every CVE Search/ Get API key

CVE-2022-40320

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

8.8 HighFix available

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.46%Up 0.6 points since Sep 10, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
CVE-2022-40320
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
CVE-2022-40320
Updated
2026-11-02
EUVDEUVD-2022-43611 No score

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
EUVD-2022-43611
Updated
2026-11-03
GitHub AdvisoriesGHSA-4f2q-2458-j6j8 8.8

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
GHSA-4f2q-2458-j6j8
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVAZL-10925 8.8

CVE-2022-40320 affecting package libconfuse for versions less than 3.3-2

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
AZL-10925
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVAZL-34910 8.8

CVE-2022-40320 affecting package libconfuse for versions less than 3.3-2

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
AZL-34910
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-05
Show 8 moreShow less
OSVDEBIAN-CVE-2022-40320 8.8

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
DEBIAN-CVE-2022-40320
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSVOESA-2022-1928 8.8

libconfuse security update

libConfuse is a configuration file parser library, licensed under the terms of the ISC license, and written in C. It supports sections and (lists of) values (strings, integers, floats, booleans or other sections), as well as some other features (such as single/double-quoted strings, environment variable expansion, functions and nested include statements). It makes it very easy to add configuration file capability to a program using a simple API. The goal of libConfuse is not to be the configuration file parser library with a gazillion of features. Instead, it aims to be easy to use and quick to integrate with your code.

Security Fix(es):

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.(CVE-2022-40320)

Record
OESA-2022-1928
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2022-40320 8.8

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
UBUNTU-CVE-2022-40320
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV No score

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.

Record
CVE-2022-40320
Updated
2026-11-02
OSVMGASA-2022-0387 No score

Updated libconfuse packages fix security vulnerability

cfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read. (CVE-2022-40320)

Record
MGASA-2022-0387
Updated
2026-11-02
OSVopenSUSE-SU-2024:12324-1 No score

libconfuse-devel-3.3-2.1 on GA media

These are all security issues fixed in the libconfuse-devel-3.3-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12324-1
Updated
2026-11-02
OSVSUSE-SU-2022:3331-1 No score

Security update for libconfuse0

This update for libconfuse0 fixes the following issues:

  • CVE-2022-40320: Fixed a heap-based buffer over-read in cfg_tilde_expand in confuse.c (bsc#1203326).
Record
SUSE-SU-2022:3331-1
Updated
2026-11-02
OSVSUSE-SU-2022:3807-1 No score

Security update for libconfuse0

This update for libconfuse0 fixes the following issues:

  • CVE-2022-40320: Fixed a heap-based buffer over-read in cfg_tilde_expand in confuse.c (bsc#1203326).
Record
SUSE-SU-2022:3807-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libconfuse
Azure Linux:2
before 3.3-2
3.3-2
libconfuse
Azure Linux:3
before 3.3-2
3.3-2
libconfuse
Debian:12
before 3.3-3
3.3-3
libconfuse
Debian:13
before 3.3-3
3.3-3
libconfuse
Debian:14
before 3.3-3
3.3-3
libconfuse
Mageia:8
before 3.3-1.1.mga8
3.3-1.1.mga8
libconfuse
openEuler:20.03-LTS-SP1
before 3.3-2.oe1
3.3-2.oe1
libconfuse
openEuler:20.03-LTS-SP3
before 3.3-2.oe1
3.3-2.oe1
libconfuse
openEuler:22.03-LTS
before 3.3-2.oe2203
3.3-2.oe2203
libconfuse0
SUSE:Linux Enterprise Module for HPC 12
before 2.8-3.6.1
2.8-3.6.1
Show 16 moreShow less
Affected packages
PackageAffectedFixed
libconfuse0
SUSE:Linux Enterprise Module for HPC 15 SP3
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
SUSE:Linux Enterprise Module for Package Hub 15 SP3
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
SUSE:Linux Enterprise Module for Package Hub 15 SP4
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
SUSE:Linux Enterprise High Performance Computing 15-ESPOS
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
SUSE:Linux Enterprise High Performance Computing 15-LTSS
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
openSUSE:Leap 15.3
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse0
openSUSE:Leap 15.4
before 2.8-150000.3.3.1
2.8-150000.3.3.1
libconfuse
Ubuntu:22.04:LTS
All versions, plus listed versions
3.3-2
None known
libconfuse
Ubuntu:24.04:LTS
All versions, plus listed versions
3.3-33.3-3build1
None known
libconfuse
Ubuntu:25.10
All versions, plus listed versions
3.3-3build13.3-4
None known
libconfuse
Ubuntu:26.10
All versions, plus listed versions
3.3-4build13.4-1
None known
libconfuse
Ubuntu:26.04:LTS
All versions, plus listed versions
3.3-43.3-4build1
None known

History

History
RecordedChangedSources
factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-40320 is a high vulnerability (CVSS 8.8) in Libconfuse Project Libconfuse, published September 9, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.46%, the 73rd percentile. Fixed in libconfuse 3.3-2.

References

Show 15 moreShow less
MoveEnter Open