Every CVE Search/ Get API key

CVE-2022-41654

ghost vulnerable to unauthorized newsletter modification via improper access controls

9.6 CriticalFix available

An authentication bypass vulnerability exists in the newsletter subscription functionality of Ghost Foundation Ghost 5.9.4. A specially-crafted HTTP request can lead to increased privileges. An attacker can send an HTTP request to trigger this vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

18.9%Up 18.0 points since Dec 23, 2022
90%50%10%1%

What each source reports

CVE List Score used 9.6

An authentication bypass vulnerability exists in the newsletter subscription functionality of Ghost Foundation Ghost 5.9.4. A specially-crafted HTTP request can lead to increased privileges. An attacker can send an HTTP request to trigger this vulnerability.

Record
CVE-2022-41654
CVSS 3.0
9.6 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-284
Updated
2026-11-02
EUVDEUVD-2022-7303 9.6

An authentication bypass vulnerability exists in the newsletter subscription functionality of Ghost Foundation Ghost 5.9.4. A specially-crafted HTTP request can lead to increased privileges. An attacker can send an HTTP request to trigger this vulnerability.

Record
EUVD-2022-7303
CVSS 3.0
9.6 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-9gh8-wp53-ccc6 8.5

ghost vulnerable to unauthorized newsletter modification via improper access controls

Impact

On sites where members is enabled (this is the default) it is possible for members (unprivileged users) to make changes to newsletter settings. This gives unprivileged users the ability to view and change settings they were not intended to have access to. They are not able to escalate their privileges permanently or get access to further information. This issue was caused by a gap in our API validation for nested objects.

Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added.

Self-hosters are impacted if running Ghost a version between v4.46.0 and v4.48.7 or any version of v5 prior to v5.22.7. Immediate action should be taken to secure your site - see patches & workarounds below.

Patches

  • v4.48.8 / v5.22.7 are patched for all known exploits.
  • v4.48.9 / v5.24.1 contain deeper fixes to the API to close the potential for this vulnerability to appear elsewhere or regress

Workarounds

The known exploit can be prevented by disabling members until an update can be performed.

References

For more information

If you have any questions or comments about this advisory:


Credits: Dave McDaniel and other members of Cisco Talos

Record
GHSA-9gh8-wp53-ccc6
CVSS 3.1
8.5 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N
Weakness
CWE-284
Updated
2026-11-02
NVD 4.3

An authentication bypass vulnerability exists in the newsletter subscription functionality of Ghost Foundation Ghost 5.9.4. A specially-crafted HTTP request can lead to increased privileges. An attacker can send an HTTP request to trigger this vulnerability.

Record
CVE-2022-41654
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
CVSS 3.0
9.6 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-284
Updated
2026-11-02
OSV 9.6

An authentication bypass vulnerability exists in the newsletter subscription functionality of Ghost Foundation Ghost 5.9.4. A specially-crafted HTTP request can lead to increased privileges. An attacker can send an HTTP request to trigger this vulnerability.

Record
CVE-2022-41654
CVSS 3.0
9.6 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-284
Updated
2026-11-02
OSVGHSA-9gh8-wp53-ccc6 8.5

ghost vulnerable to unauthorized newsletter modification via improper access controls

Impact

On sites where members is enabled (this is the default) it is possible for members (unprivileged users) to make changes to newsletter settings. This gives unprivileged users the ability to view and change settings they were not intended to have access to. They are not able to escalate their privileges permanently or get access to further information. This issue was caused by a gap in our API validation for nested objects.

Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added.

Self-hosters are impacted if running Ghost a version between v4.46.0 and v4.48.7 or any version of v5 prior to v5.22.7. Immediate action should be taken to secure your site - see patches & workarounds below.

Patches

  • v4.48.8 / v5.22.7 are patched for all known exploits.
  • v4.48.9 / v5.24.1 contain deeper fixes to the API to close the potential for this vulnerability to appear elsewhere or regress

Workarounds

The known exploit can be prevented by disabling members until an update can be performed.

References

For more information

If you have any questions or comments about this advisory:


Credits: Dave McDaniel and other members of Cisco Talos

Record
GHSA-9gh8-wp53-ccc6
CVSS 3.1
8.5 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N
Weakness
CWE-284
Updated
2026-11-02
OSVBIT-ghost-2022-41654 No score

An authentication bypass vulnerability exists in the newsletter subscription functionality of Ghost Foundation Ghost 5.9.4. A specially-crafted HTTP request can lead to increased privileges. An attacker can send an HTTP request to trigger this vulnerability.

Record
BIT-ghost-2022-41654
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ghost
npm
5.0.0 up to 5.22.7
5.22.7
ghost
npm
4.46.0 up to 4.48.8
4.48.8
ghost
Bitnami
4.46.0 up to 4.48.8, 5.0.0 up to 5.22.7
4.48.85.22.7

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-41654 is a critical vulnerability (CVSS 9.6) in Ghost, published November 28, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 18.9%, the 97th percentile. Fixed in ghost 5.22.7.

References

MoveEnter Open