CVE-2022-42468
Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource
Apache Flume versions 1.4.0 through 1.10.1 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Apache Flume versions 1.4.0 through 1.10.1 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.
- Record
CVE-2022-42468- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-74
- Updated
- 2026-11-02
CVE List
9.8
Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource
Apache Flume versions 1.4.0 through 1.10.1 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.
- Record
CVE-2022-42468- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-74
- Updated
- 2026-11-02
EUVDEUVD-2022-7069
9.8
Apache Flume versions 1.4.0 through 1.10.1 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.
- Record
EUVD-2022-7069- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9w4g-fp9h-3q2v
9.8
Apache Flume vulnerable to remote code execution via deserialization of unsafe providerURL
Flume’s JMSSource class can be configured with a providerUrl parameter. A JNDI lookup is performed on this name without performing validation. This could result in untrusted data being deserialized, leading to remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed in version 1.11.0.
- Record
GHSA-9w4g-fp9h-3q2v- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-502
- Updated
- 2026-11-02
OSVGHSA-9w4g-fp9h-3q2v
9.8
Apache Flume vulnerable to remote code execution via deserialization of unsafe providerURL
Flume’s JMSSource class can be configured with a providerUrl parameter. A JNDI lookup is performed on this name without performing validation. This could result in untrusted data being deserialized, leading to remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed in version 1.11.0.
- Record
GHSA-9w4g-fp9h-3q2v- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-502
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.flume.flume-ng-sources:flume-jms-sourceMaven |
before 1.11.0 | 1.11.0 |
org.apache.flume.flume-ng-sources:flume-jms-sourceMaven |
before 1.11.0, plus listed versions 1.10.01.10.11.4.01.5.01.5.0.1 Show 6 moreShow less1.5.11.5.21.6.01.7.01.8.01.9.0 |
1.11.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-42468 is a critical vulnerability (CVSS 9.8) in Apache Flume, published October 26, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.72%, the 89th percentile. Fixed in org.apache.flume.flume-ng-sources:flume-jms-source 1.11.0.
References
issues.apache.org/jira/browse/FLUME-3437
lists.apache.org/thread/939wkx8o90bp6m2ht3t1sdyo1ncypl78
lists.apache.org/thread/1ckhmp539zr2nd2rs45pocpywk2d9zvz
nvd.nist.gov/vuln/detail/CVE-2022-42468
github.com/apache/flume/commit/eee179a09df405c1ab55ae25a53b76ca1050bb97
github.com/advisories/GHSA-9w4g-fp9h-3q2v
github.com/apache/flume