CVE-2022-43500
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote...
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
- Record
CVE-2022-43500- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List
6.1
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
- Record
CVE-2022-43500- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-46498
6.1
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
- Record
EUVD-2022-46498- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hm6q-fjph-v26v
6.1
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote...
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script .
- Record
GHSA-hm6q-fjph-v26v- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
- Record
CVE-2022-43500- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-43500
6.1
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
- Record
UBUNTU-CVE-2022-43500- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVBIT-wordpress-2022-43500 No score
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
- Record
BIT-wordpress-2022-43500- Updated
- 2026-11-02
OSVBIT-wordpress-multisite-2022-43500 No score
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
- Record
BIT-wordpress-multisite-2022-43500- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-43500 No score
Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.
- Record
DEBIAN-CVE-2022-43500- Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressBitnami |
before 3.7.40, 3.8.0 up to 3.8.40, 3.9.0 up to 3.9.39, 4.0.0 up to 4.0.37, 4.1.0 up to 4.1.37, 4.2.0 up to 4.2.34, 4.3.0 up to 4.3.30, 4.4.0 up to 4.4.29, 4.5.0 up to 4.5.28, 4.6.0 up to 4.6.25, 4.7.0 up to 4.7.25, 4.8.0 up to 4.8.21, 4.9.0 up to 4.9.22, 5.0.0 up to 5.0.18, 5.1.0 up to 5.1.15, 5.2.0 up to 5.2.17, 5.3.0 up to 5.3.14, 5.4.0 up to 5.4.12, 5.5.0 up to 5.5.11, 5.6.0 up to 5.6.10, 5.7.0 up to 5.7.8, 5.8.0 up to 5.8.6, 5.9.0 up to 5.9.5, 6.0.0 up to 6.0.3 | 3.7.403.8.403.9.394.0.374.1.374.2.344.3.304.4.294.5.284.6.254.7.254.8.214.9.225.0.185.1.155.2.175.3.145.4.125.5.115.6.105.7.85.8.65.9.56.0.3 |
wordpress-multisiteBitnami |
before 3.7.40, 3.8.0 up to 3.8.40, 3.9.0 up to 3.9.39, 4.0.0 up to 4.0.37, 4.1.0 up to 4.1.37, 4.2.0 up to 4.2.34, 4.3.0 up to 4.3.30, 4.4.0 up to 4.4.29, 4.5.0 up to 4.5.28, 4.6.0 up to 4.6.25, 4.7.0 up to 4.7.25, 4.8.0 up to 4.8.21, 4.9.0 up to 4.9.22, 5.0.0 up to 5.0.18, 5.1.0 up to 5.1.15, 5.2.0 up to 5.2.17, 5.3.0 up to 5.3.14, 5.4.0 up to 5.4.12, 5.5.0 up to 5.5.11, 5.6.0 up to 5.6.10, 5.7.0 up to 5.7.8, 5.8.0 up to 5.8.6, 5.9.0 up to 5.9.5, 6.0.0 up to 6.0.3 | 3.7.403.8.403.9.394.0.374.1.374.2.344.3.304.4.294.5.284.6.254.7.254.8.214.9.225.0.185.1.155.2.175.3.145.4.125.5.115.6.105.7.85.8.65.9.56.0.3 |
wordpressDebian:12 |
before 6.0.3+dfsg1-1 | 6.0.3+dfsg1-1 |
wordpressDebian:13 |
before 6.0.3+dfsg1-1 | 6.0.3+dfsg1-1 |
wordpressDebian:14 |
before 6.0.3+dfsg1-1 | 6.0.3+dfsg1-1 |
wordpressDebian:11 |
before 5.7.8+dfsg1-0+deb11u1, plus listed versions 5.7.1+dfsg1-25.7.3+dfsg1-0+deb11u15.7.5+dfsg1-0+deb11u1 |
5.7.8+dfsg1-0+deb11u1 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
wordpressUbuntu:18.04:LTS |
All versions, plus listed versions 4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1 |
None known |
wordpressUbuntu:20.04:LTS |
All versions, plus listed versions 5.2.2+dfsg1-15.2.4+dfsg1-15.3.2+dfsg1-15.3.2+dfsg1-1ubuntu1 |
None known |
wordpressUbuntu:22.04:LTS |
All versions, plus listed versions 5.7.1+dfsg1-2ubuntu15.8.1+dfsg1-2ubuntu15.8.2+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu1.1 |
None known |
Show 4 moreShow less
| Package | Affected | Fixed |
|---|---|---|
wordpressUbuntu:24.04:LTS |
All versions, plus listed versions 6.2+dfsg1-1ubuntu16.4.3+dfsg1-1ubuntu1 |
None known |
wordpressUbuntu:25.10 |
All versions, plus listed versions 6.7.2+dfsg1-1.1ubuntu1 |
None known |
wordpressUbuntu:26.10 |
All versions, plus listed versions 6.7.2+dfsg1-1.1ubuntu2 |
None known |
wordpressUbuntu:26.04:LTS |
All versions, plus listed versions 6.7.2+dfsg1-1.1ubuntu16.7.2+dfsg1-1.1ubuntu2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-43500 is a medium vulnerability (CVSS 6.1) in Wordpress, published November 15, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in wordpress 3.7.40.
References
wordpress.org/download
wordpress.org/news/2022/10/wordpress-6-0-3-security-release
jvn.jp/en/jp/JVN09409909/index.html
nvd.nist.gov/vuln/detail/CVE-2022-43500
github.com/advisories/GHSA-hm6q-fjph-v26v
github.com/CVEProject/cvelistV5/tree/main/cves/2022/43xxx/CVE-2022-43500.json
security-tracker.debian.org/tracker/CVE-2022-43500
ubuntu.com/security/CVE-2022-43500
cve.org/CVERecord?id=CVE-2022-43500