Every CVE Search/ Get API key

CVE-2022-43507

Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may...

7.5 HighFix available

Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may allow a privileged user to potentially enable escalation of privilege via network access.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.61%Up 0.6 points since May 11, 2023
90%50%10%1%

What each source reports

CVE List Score used 7.5

Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may allow a privileged user to potentially enable escalation of privilege via network access.

Record
CVE-2022-43507
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-92
Updated
2026-11-02
EUVDEUVD-2022-46505 7.5

Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may allow a privileged user to potentially enable escalation of privilege via network access.

Record
EUVD-2022-46505
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-qq3q-8ccj-3w3c 7.5

Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may...

Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may allow a privileged user to potentially enable escalation of privilege via network access.

Record
GHSA-qq3q-8ccj-3w3c
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
NVD 7.5

Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may allow a privileged user to potentially enable escalation of privilege via network access.

Record
CVE-2022-43507
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-92, CWE-120
Updated
2026-11-02
OSV 8.8

Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may allow a privileged user to potentially enable escalation of privilege via network access.

Record
CVE-2022-43507
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVSUSE-SU-2023:3290-1 No score

Security update for qatengine

This update for qatengine fixes the following issues:

  • CVE-2022-43507: Fixed a buffer overflow issue with SHA3. (bsc#1211296)
Record
SUSE-SU-2023:3290-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qatengine
SUSE:Linux Enterprise Module for Basesystem 15 SP4
before 0.6.10-150400.3.3.1
0.6.10-150400.3.3.1
qatengine
openSUSE:Leap 15.4
before 0.6.10-150400.3.3.1
0.6.10-150400.3.3.1

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-43507 is a high vulnerability (CVSS 7.5) in Intel Quickassist Technology Engine, published May 10, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in qatengine 0.6.10-150400.3.3.1.

References

MoveEnter Open