Every CVE Search/ Get API key

CVE-2022-43756

Rancher/Wrangler: Denial of service when processing Git credentials

5.9 MediumFix available

A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
High

Exploit likelihood

0.68%Down 0.4 points since Feb 8, 2023
90%50%10%1%

What each source reports

CVE List Score used 5.9

Rancher/Wrangler: Denial of service when processing Git credentials

A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.

Record
CVE-2022-43756
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
Weakness
CWE-74
Updated
2026-11-02
EUVDEUVD-2023-0407 5.9

A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.

Record
EUVD-2023-0407
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-8fcj-gf77-47mg 5.9

Denial of service (DoS) when processing Git credentials

Impact

A denial of services (DoS) vulnerability was discovered in Wrangler Git package affecting versions up to and including v1.0.0.

Specially crafted Git credentials can result in a denial of service (DoS) attack on an application that uses Wrangler due to the exhaustion of the available memory and CPU resources. This is caused by a lack of input validation of Git credentials before they are used, which may lead to a denial of service in some cases. This issue can be triggered when accessing both private and public Git repositories.

Workarounds

A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version.

Patches

Patched versions include v1.0.1 and later and the backported tags - v0.7.4-security1, v0.8.5-security1 and v0.8.11.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-8fcj-gf77-47mg
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
Weakness
CWE-74, CWE-150
Updated
2026-11-02
NVD 5.9

A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.

Record
CVE-2022-43756
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-74
Updated
2026-11-02
OSV 5.9

Rancher/Wrangler: Denial of service when processing Git credentials

A Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in SUSE Rancher allows remote attackers to cause denial of service by supplying specially crafted git credentials. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.

Record
CVE-2022-43756
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
Weakness
CWE-74
Updated
2026-11-02
OSVGHSA-8fcj-gf77-47mg 5.9

Denial of service (DoS) when processing Git credentials

Impact

A denial of services (DoS) vulnerability was discovered in Wrangler Git package affecting versions up to and including v1.0.0.

Specially crafted Git credentials can result in a denial of service (DoS) attack on an application that uses Wrangler due to the exhaustion of the available memory and CPU resources. This is caused by a lack of input validation of Git credentials before they are used, which may lead to a denial of service in some cases. This issue can be triggered when accessing both private and public Git repositories.

Workarounds

A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version.

Patches

Patched versions include v1.0.1 and later and the backported tags - v0.7.4-security1, v0.8.5-security1 and v0.8.11.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-8fcj-gf77-47mg
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
Weakness
CWE-150, CWE-74
Updated
2026-11-02
OSVGO-2023-1515 No score

Denial of service when processing Git credentials in github.com/rancher/wrangler

A denial of service (DoS) vulnerability exists in the Wrangler Git package. Specially crafted Git credentials can result in a denial of service (DoS) attack on an application that uses Wrangler due to the exhaustion of the available memory and CPU resources.

This is caused by a lack of input validation of Git credentials before they are used, which may lead to a denial of service in some cases. This issue can be triggered when accessing both private and public Git repositories.

A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version.

Record
GO-2023-1515
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/rancher/wrangler
Go
through 0.7.3
0.7.4-security1
github.com/rancher/wrangler
Go
0.8.0 to 0.8.4
0.8.5-security1
github.com/rancher/wrangler
Go
1.0.0 to 1.0.0
1.0.1
github.com/rancher/wrangler
Go
0.8.6 up to 0.8.11
0.8.11
github.com/rancher/wrangler
Go
before 0.7.4-security1
0.7.4-security1
github.com/rancher/wrangler
Go
0.8.0 up to 0.8.5-security1
0.8.5-security1
github.com/rancher/wrangler
Go
1.0.0 up to 1.0.1
1.0.1
github.com/rancher/wrangler
Go
before 0.7.4-security1, 0.8.0 up to 0.8.5-security1, 0.8.6 up to 0.8.11, 1.0.0 up to 1.0.1
0.7.4-security10.8.5-security10.8.111.0.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-43756 is a medium vulnerability (CVSS 5.9) in Suse Rancher, published January 25, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in github.com/rancher/wrangler 0.7.4-security1.

References

MoveEnter Open