CVE-2022-45462
Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher
- Record
CVE-2022-45462- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
CVE List
9.8
Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher
- Record
CVE-2022-45462- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
EUVDEUVD-2022-7456
9.8
Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher
- Record
EUVD-2022-7456- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wqg7-mx6p-2rw3
9.8
Command injection in Apache DolphinScheduler Alert Plugins
Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher.
- Record
GHSA-wqg7-mx6p-2rw3- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV
9.8
Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher
- Record
CVE-2022-45462- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSVGHSA-wqg7-mx6p-2rw3
9.8
Command injection in Apache DolphinScheduler Alert Plugins
Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher.
- Record
GHSA-wqg7-mx6p-2rw3- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.dolphinscheduler:dolphinscheduler-alert-pluginsMaven |
before 2.0.6 | 2.0.6 |
org.apache.dolphinscheduler:dolphinscheduler-alert-pluginsMaven |
before 2.0.6, plus listed versions 2.0.12.0.22.0.32.0.42.0.5 |
2.0.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-45462 is a critical vulnerability (CVSS 9.8) in Apache Dolphinscheduler, published November 23, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.89%, the 86th percentile. Fixed in org.apache.dolphinscheduler:dolphinscheduler-alert-plugins 2.0.6.
References
lists.apache.org/thread/2f126y32bf1v3mvxkdgt2jr5j3l1t01w
openwall.com/lists/oss-security/2022/11/23/1
nvd.nist.gov/vuln/detail/CVE-2022-45462
github.com/apache/dolphinscheduler/pull/10744
github.com/apache/dolphinscheduler/pull/9834
github.com/advisories/GHSA-wqg7-mx6p-2rw3
github.com/CVEProject/cvelistV5/tree/main/cves/2022/45xxx/CVE-2022-45462.json
github.com/apache/dolphinscheduler