CVE-2022-47655
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
- Record
CVE-2022-47655- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List
7.8
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
- Record
CVE-2022-47655- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2022-50414
7.8
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
- Record
EUVD-2022-50414- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-m9c9-fqf4-w6xr
7.8
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
- Record
GHSA-m9c9-fqf4-w6xr- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-47655
7.8
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
- Record
ALPINE-CVE-2022-47655- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
7.8
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
- Record
CVE-2022-47655- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-47655 No score
Libde265 1.0.9 is vulnerable to Buffer Overflow in function void put_qpel_fallback<unsigned short>
- Record
DEBIAN-CVE-2022-47655- Updated
- 2026-11-03
OSVMGASA-2023-0093 No score
Updated libde265 packages fix security vulnerability
libde265 has been updated to version 1.0.11 to fix many security issues.
- Record
MGASA-2023-0093- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libde265Alpine:v3.14 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.15 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.16 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.17 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.18 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.19 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.20 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.21 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.22 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Alpine:v3.23 |
before 1.0.11-r0 | 1.0.11-r0 |
Show 8 moreShow less
| Package | Affected | Fixed |
|---|---|---|
libde265Alpine:v3.24 |
before 1.0.11-r0 | 1.0.11-r0 |
libde265Debian:12 |
before 1.0.9-1.1 | 1.0.9-1.1 |
libde265Debian:13 |
before 1.0.9-1.1 | 1.0.9-1.1 |
libde265Debian:14 |
before 1.0.9-1.1 | 1.0.9-1.1 |
libde265Debian:10 From an advisory covering 20 CVEs |
before 1.0.3-1+deb10u3, plus listed versions 1.0.3-11.0.3-1+deb10u11.0.3-1+deb10u2 |
1.0.3-1+deb10u3 |
libde265Debian:11 From an advisory covering 46 CVEs |
before 1.0.11-0+deb11u1, plus listed versions 1.0.8-11.0.8-1.11.0.9-11.0.9-1.1 |
1.0.11-0+deb11u1 |
libde265Mageia:8 From an advisory covering 46 CVEs |
before 1.0.11-1.mga8 | 1.0.11-1.mga8 |
libde265Mageia:8 From an advisory covering 46 CVEs |
before 1.0.11-1.mga8.tainted | 1.0.11-1.mga8.tainted |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-47655 is a high vulnerability (CVSS 7.8) in Struktur Libde265, published January 5, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in libde265 1.0.11-r0.
References
github.com/strukturag/libde265/issues/367
lists.debian.org/debian-lts-announce/2023/01/msg00020.html
debian.org/security/2023/dsa-5346
nvd.nist.gov/vuln/detail/CVE-2022-47655
github.com/advisories/GHSA-m9c9-fqf4-w6xr
security.alpinelinux.org/vuln/CVE-2022-47655
Show 7 moreShow less
github.com/CVEProject/cvelistV5/tree/main/cves/2022/47xxx/CVE-2022-47655.json
security-tracker.debian.org/tracker/CVE-2022-47655
advisories.mageia.org/MGASA-2023-0093.html
bugs.mageia.org/show_bug.cgi?id=31289
debian.org/lts/security/2022/dla-3240
debian.org/lts/security/2023/dla-3280
debian.org/lts/security/2023/dla-3352