CVE-2022-4805
Incorrect Use of Privileged APIs in usememos/memos
Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.3
Incorrect Use of Privileged APIs in usememos/memos
Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4805- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-648
- Updated
- 2026-11-02
EUVDEUVD-2022-7691
7.3
Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.1.
- Record
EUVD-2022-7691- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mq5q-gpgv-pwxw
4.3
usememos/memos Incorrect Use of Privileged APIs vulnerability
In usememos/memos 0.9.0 and prior, a user can archive any private memos, delete any shortcut, and edit any shortcut from other users via API.
- Record
GHSA-mq5q-gpgv-pwxw- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-648
- Updated
- 2026-11-02
NVD
4.3
Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4805- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-648
- Updated
- 2026-11-02
OSV
7.3
Incorrect Use of Privileged APIs in usememos/memos
Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.1.
- Record
CVE-2022-4805- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-648
- Updated
- 2026-11-02
OSVGHSA-mq5q-gpgv-pwxw
4.3
usememos/memos Incorrect Use of Privileged APIs vulnerability
In usememos/memos 0.9.0 and prior, a user can archive any private memos, delete any shortcut, and edit any shortcut from other users via API.
- Record
GHSA-mq5q-gpgv-pwxw- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-648
- Updated
- 2026-11-02
OSVGO-2023-1292 No score
usememos/memos Incorrect Use of Privileged APIs vulnerability in github.com/usememos/memos
usememos/memos Incorrect Use of Privileged APIs vulnerability in github.com/usememos/memos
- Record
GO-2023-1292- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/usememos/memosGo |
through 0.9.0 | 0.9.1 |
github.com/usememos/memosGo |
before 0.9.1 | 0.9.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-4805 is a high vulnerability (CVSS 7.3) in Usememos Memos, published December 28, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in github.com/usememos/memos 0.9.1.
References
github.com/usememos/memos/commit/3556ae4e651d9443dc3bb8a170dd3cc726517a53
huntr.dev/bounties/b03f6a9b-e49b-42d6-a318-1d7afd985873
nvd.nist.gov/vuln/detail/CVE-2022-4805
github.com/advisories/GHSA-mq5q-gpgv-pwxw
github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4805.json
github.com/usememos/memos