Every CVE Search/ Get API key

CVE-2022-4840

Cross-site Scripting (XSS) - Stored in usememos/memos

7.6 HighFix available

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
High

Exploit likelihood

0.70%Down 0.2 points since Dec 30, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.6

Cross-site Scripting (XSS) - Stored in usememos/memos

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.

Record
CVE-2022-4840
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-7710 7.6

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.

Record
EUVD-2022-7710
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-pwhr-p68w-296x 5.4

usememos/memos vulnerable to stored Cross-site Scripting

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos 0.9.0 and prior.

Record
GHSA-pwhr-p68w-296x
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.

Record
CVE-2022-4840
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
Weakness
CWE-79
Updated
2026-11-02
OSV 7.6

Cross-site Scripting (XSS) - Stored in usememos/memos

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.

Record
CVE-2022-4840
CVSS 3.0
7.6 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-pwhr-p68w-296x 5.4

usememos/memos vulnerable to stored Cross-site Scripting

Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos 0.9.0 and prior.

Record
GHSA-pwhr-p68w-296x
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/usememos/memos
Go
through 0.9.0
0.9.1
github.com/usememos/memos
Go
before 0.9.1
0.9.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-4840 is a high vulnerability (CVSS 7.6) in Usememos Memos, published December 29, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.70%, the 53rd percentile. Fixed in github.com/usememos/memos 0.9.1.

References

MoveEnter Open