CVE-2022-48620
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
- Record
CVE-2022-48620- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List
9.8
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
- Record
CVE-2022-48620- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2022-51315
9.8
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
- Record
EUVD-2022-51315- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hjg8-pr7m-gj33
9.8
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
- Record
GHSA-hjg8-pr7m-gj33- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
9.8
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
- Record
CVE-2022-48620- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-48620
9.8
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
- Record
UBUNTU-CVE-2022-48620- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-48620 No score
uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.
- Record
DEBIAN-CVE-2022-48620- Updated
- 2026-11-03
OSVopenSUSE-SU-2024:0023-1 No score
Security update for libuev
This update for libuev fixes the following issues:
-
Update to 2.4.1:
- Update README with list of moden Linux APIs used
- Fix #27: possible buffer overrun in uev_run() boo#1218749 CVE-2022-48620
- Record
openSUSE-SU-2024:0023-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13578-1 No score
libuev-devel-2.4.1-2.1 on GA media
These are all security issues fixed in the libuev-devel-2.4.1-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13578-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libuevDebian:12 |
before 2.4.0-1.1+deb12u1, plus listed versions 2.4.0-1.1 |
2.4.0-1.1+deb12u1 |
libuevDebian:13 |
before 2.4.1-1 | 2.4.1-1 |
libuevDebian:14 |
before 2.4.1-1 | 2.4.1-1 |
libuevDebian:11 |
before 2.3.1-1+deb11u1, plus listed versions 2.3.1-1 |
2.3.1-1+deb11u1 |
libuevUbuntu:22.04:LTS |
All versions, plus listed versions 2.3.1-1ubuntu22.4.0-1.1 |
None known |
libuevUbuntu:24.04:LTS |
All versions, plus listed versions 2.4.0-1.12.4.0-1.22.4.1-12.4.1-1build1 |
None known |
libuevUbuntu:25.10 |
All versions, plus listed versions 2.4.1-1build1 |
None known |
libuevUbuntu:26.10 |
All versions, plus listed versions 2.4.1-1build2 |
None known |
libuevUbuntu:26.04:LTS |
All versions, plus listed versions 2.4.1-1build12.4.1-1build2 |
None known |
libuevSUSE:Package Hub 15 SP5 |
before 2.4.1-bp155.3.3.1 | 2.4.1-bp155.3.3.1 |
libuevopenSUSE:Leap 15.5 |
before 2.4.1-bp155.3.3.1 | 2.4.1-bp155.3.3.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-48620 is a critical vulnerability (CVSS 9.8) in Troglobit Libeuv, published January 12, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.32%, the 71st percentile. Fixed in libuev 2.4.0-1.1+deb12u1.
References
github.com/troglobit/libuev/issues/27
github.com/troglobit/libuev/compare/v2.4.0...v2.4.1
github.com/troglobit/libuev/commit/2d9f1c9ce655cc38511aeeb6e95ac30914f7aec9
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2J4UB4KXWCCTZCE53B6SFIREZ57INK7T
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P2XZESYGE6XDWAPFUOX26ZWJV2JWMMM5
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/E6RLVLJGDKTEVJP446TFDANHB4LHRAOP
Show 13 moreShow less
lists.fedoraproject.org/archives/list/[email protected]/message/2J4UB4KXWCCTZCE53B6SFIREZ57INK7T
lists.fedoraproject.org/archives/list/[email protected]/message/E6RLVLJGDKTEVJP446TFDANHB4LHRAOP
lists.fedoraproject.org/archives/list/[email protected]/message/P2XZESYGE6XDWAPFUOX26ZWJV2JWMMM5
lists.debian.org/debian-lts-announce/2026/01/msg00026.html
nvd.nist.gov/vuln/detail/CVE-2022-48620
github.com/advisories/GHSA-hjg8-pr7m-gj33
github.com/CVEProject/cvelistV5/tree/main/cves/2022/48xxx/CVE-2022-48620.json
security-tracker.debian.org/tracker/CVE-2022-48620
ubuntu.com/security/CVE-2022-48620
cve.org/CVERecord?id=CVE-2022-48620
lists.opensuse.org/archives/list/[email protected]/thread/EEXA2EZOHQFRCE3KOKKQIYMIW7OG2YYR
bugzilla.suse.com/1218749
suse.com/security/cve/CVE-2022-48620