Every CVE Search/ Get API key

CVE-2022-48623

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that...

9.1 CriticalFix available

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

0.79%Up 0.7 points since Feb 13, 2024
90%50%10%1%

What each source reports

NVD Score used 9.1

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
CVE-2022-48623
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
CVE List 9.1

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
CVE-2022-48623
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
EUVDEUVD-2022-51318 9.1

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
EUVD-2022-51318
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-44qr-8pf6-6q33 9.1

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that...

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
GHSA-44qr-8pf6-6q33
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVAZL-43660 9.1

CVE-2022-48623 affecting package perl-Cpanel-JSON-XS 4.27-2

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
AZL-43660
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVAZL-44766 9.1

CVE-2022-48623 affecting package perl-Cpanel-JSON-XS for versions less than 4.39-1

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
AZL-44766
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSV 9.1

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
CVE-2022-48623
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2022-48623 9.1

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
UBUNTU-CVE-2022-48623
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-48623 No score

The Cpanel::JSON::XS package before 4.33 for Perl performs out-of-bounds accesses in a way that allows attackers to obtain sensitive information or cause a denial of service.

Record
DEBIAN-CVE-2022-48623
Updated
2026-11-03
OSVROOT-OS-DEBIAN-11-CVE-2022-48623 No score

CVE-2022-48623 in libcpanel-json-xs-perl - Patched by Root

Root has patched CVE-2022-48623 in the libcpanel-json-xs-perl package for Root:Debian:11. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-11-CVE-2022-48623
Updated
2026-11-02
OSVUSN-6667-1 No score

libcpanel-json-xs-perl vulnerability

It was discovered that Cpanel-JSON-XS incorrectly decoded certain data. A remote attacker could use this issue to cause Cpanel-JSON-XS to crash, resulting in a denial of service, or possibly obtain sensitive information.

Record
USN-6667-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
perl-Cpanel-JSON-XS
Azure Linux:2
through 4.27-2 None known
perl-Cpanel-JSON-XS
Azure Linux:3
before 4.39-1
4.39-1
libcpanel-json-xs-perl
Debian:12
before 4.35-1
4.35-1
libcpanel-json-xs-perl
Debian:13
before 4.35-1
4.35-1
libcpanel-json-xs-perl
Debian:14
before 4.35-1
4.35-1
libcpanel-json-xs-perl
Root:Debian:11
before 4.25-1+deb11u1.root.io.1
4.25-1+deb11u1.root.io.14.25-1+deb11u1.root.io.24.25-1+deb11u1.root.io.44.25-1+deb11u1.root.io.54.25-1+deb11u1.root.io.34.25-1+deb11u1.aikido.64.25-1+deb11u1.aikido.7
rootio-libcpanel-json-xs-perl
Root:Debian:11
before 4.25-1+deb11u1.root.io.1
4.25-1+deb11u1.root.io.14.25-1+deb11u1.root.io.24.25-1+deb11u1.root.io.44.25-1+deb11u1.root.io.54.25-1+deb11u1.root.io.34.25-1+deb11u1.aikido.64.25-1+deb11u1.aikido.7
libcpanel-json-xs-perl
Ubuntu:16.04:LTS
All versions, plus listed versions
3.0115-13.0210-1ubuntu1
None known
libcpanel-json-xs-perl
Ubuntu:18.04:LTS
All versions, plus listed versions
3.0225-1build13.0239-1
None known
libcpanel-json-xs-perl
Ubuntu:20.04:LTS
before 4.19-1ubuntu0.1, plus listed versions
4.12-14.12-1build14.15-14.17-14.18-14.19-14.19-1build1
4.19-1ubuntu0.1
libcpanel-json-xs-perl
Ubuntu:22.04:LTS
before 4.27-1ubuntu0.1, plus listed versions
4.25-1build14.25-1build24.27-14.27-1build1
4.27-1ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-48623 is a critical vulnerability (CVSS 9.1) in Cpanel, published February 13, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.79%, the 56th percentile. Fixed in perl-Cpanel-JSON-XS 4.39-1.

References

Show 5 moreShow less
MoveEnter Open