Every CVE Search/ Get API key

CVE-2022-51010

PocketMine-MP before 4.4.2 Server Crash via Item ID

7.1 HighFix available

PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.53%Unchanged since Sep 8, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.1

PocketMine-MP before 4.4.2 Server Crash via Item ID

PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.

Record
CVE-2022-51010
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2022-56039 7.1

PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.

Record
EUVD-2022-56039
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-92gq-jvgx-hx4m 7.1

PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in...

PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.

Record
GHSA-92gq-jvgx-hx4m
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
GitHub AdvisoriesGHSA-fqx3-r75h-vc89 7.5

Improperly checked IDs on itemstacks received from the client leading to server crash in PocketMine-MP

Impact

Due to a workaround for unmapped network items implemented in 4.0.0-BETA5 (8ac16345a3bc099b62c1f5cfbf3b736e621c3f76), arbitrary item IDs are able to be written into an item's NBT. The intended purpose of this is to make said unmapped network items able to be moved around the inventory without issues.

This led to an exploit due to internal limits on the range that item IDs can occupy (-32768 - 32767), while the tag type used to represent the replacement IDs for unknown items is a TAG_Int, allowing a range from -(2^31) - 2^31 - 1. This leads to an uncaught exception which crashes the server.

Patches

5fd685e07d61ef670584ed11a52fd5f4b99a81a7

Workarounds

In theory this can be checked by plugins using a custom TypeConverter, but this is likely to be very cumbersome.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-fqx3-r75h-vc89
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
NVD 7.1

PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.

Record
CVE-2022-51010
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 7.1

PocketMine-MP before 4.4.2 Server Crash via Item ID

PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.

Record
CVE-2022-51010
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-fqx3-r75h-vc89 7.5

Improperly checked IDs on itemstacks received from the client leading to server crash in PocketMine-MP

Impact

Due to a workaround for unmapped network items implemented in 4.0.0-BETA5 (8ac16345a3bc099b62c1f5cfbf3b736e621c3f76), arbitrary item IDs are able to be written into an item's NBT. The intended purpose of this is to make said unmapped network items able to be moved around the inventory without issues.

This led to an exploit due to internal limits on the range that item IDs can occupy (-32768 - 32767), while the tag type used to represent the replacement IDs for unknown items is a TAG_Int, allowing a range from -(2^31) - 2^31 - 1. This leads to an uncaught exception which crashes the server.

Patches

5fd685e07d61ef670584ed11a52fd5f4b99a81a7

Workarounds

In theory this can be checked by plugins using a custom TypeConverter, but this is likely to be very cumbersome.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-fqx3-r75h-vc89
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pocketmine/pocketmine-mp
Packagist
4.0.0-BETA5 up to 4.4.2
4.4.2
pocketmine/pocketmine-mp
Packagist
4.0.0-BETA5 up to 4.4.2, plus listed versions
4.0.04.0.0-BETA104.0.0-BETA114.0.0-BETA124.0.0-BETA13
Show 37 moreShow less
4.0.0-BETA144.0.0-BETA154.0.0-BETA64.0.0-BETA74.0.0-BETA84.0.0-BETA94.0.14.0.24.0.34.0.44.0.54.0.64.0.74.0.84.0.94.1.04.1.0-BETA14.1.0-BETA24.2.04.2.14.2.104.2.24.2.34.2.44.2.54.2.64.2.74.2.84.2.94.3.04.3.14.3.24.3.34.3.44.4.04.4.0-BETA14.4.1
4.4.2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-51010 is a high vulnerability (CVSS 7.1) in Pmmp Pocketmine-mp, published June 7, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in pocketmine/pocketmine-mp 4.4.2.

References

MoveEnter Open