CVE-2023-0110
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.1
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
- Record
CVE-2023-0110- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2023-0581
7.1
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
- Record
EUVD-2023-0581- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x22v-qgm2-7qc7
5.4
usememos/memos vulnerable to stored Cross-site Scripting
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
- Record
GHSA-x22v-qgm2-7qc7- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.4
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
- Record
CVE-2023-0110- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
7.1
Cross-site Scripting (XSS) - Stored in usememos/memos
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
- Record
CVE-2023-0110- CVSS 3.0
- 7.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-x22v-qgm2-7qc7
5.4
usememos/memos vulnerable to stored Cross-site Scripting
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.10.0.
- Record
GHSA-x22v-qgm2-7qc7- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGO-2023-1469 No score
usememos/memos vulnerable to stored Cross-site Scripting in github.com/usememos/memos
usememos/memos vulnerable to stored Cross-site Scripting in github.com/usememos/memos
- Record
GO-2023-1469- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/usememos/memosGo |
before 0.10.0 | 0.10.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-0110 is a high vulnerability (CVSS 7.1) in Usememos Memos, published January 7, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.51%, the 43rd percentile. Fixed in github.com/usememos/memos 0.10.0.
References
github.com/usememos/memos/commit/46c13a4b7f675b92d297df6dabb4441f13c7cd9c
huntr.dev/bounties/6e4a1961-dbca-46f6-ae21-c25a621e54a7
nvd.nist.gov/vuln/detail/CVE-2023-0110
github.com/advisories/GHSA-x22v-qgm2-7qc7
github.com/CVEProject/cvelistV5/tree/main/cves/2023/0xxx/CVE-2023-0110.json
github.com/usememos/memos