Every CVE Search/ Get API key

CVE-2023-0227

Insufficient Session Expiration in pyload/pyload

8.3 HighFix available

CVE-2023-0227 is a high vulnerability (CVSS 8.3) in Pyload, published January 12, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.67%, the 52nd percentile. Fixed in pyload-ng 0.5.0b3.dev36.

Insufficient Session Expiration in GitHub repository pyload/pyload prior to 0.5.0b3.dev36.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
High
Availability
High

Exploit likelihood

0.67%Down 0.2 points since Jan 12, 2023
90%50%10%1%

What each source reports

CVE List Score used 8.3

Insufficient Session Expiration in pyload/pyload

Insufficient Session Expiration in GitHub repository pyload/pyload prior to 0.5.0b3.dev36.

Record
CVE-2023-0227
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
Weakness
CWE-613
Updated
2026-11-02
EUVDEUVD-2023-0548 8.3

Insufficient Session Expiration in GitHub repository pyload/pyload prior to 0.5.0b3.dev36.

Record
EUVD-2023-0548
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-rv9x-wmw4-44qj 6.5

Pyload Insufficient Session Expiration vulnerability

Pyload 0.5.0b3.dev35 has an Insufficient Session Expiration vulnerability. A patch is available and anticipated to be part of version 0.5.0b3.dev36.

Record
GHSA-rv9x-wmw4-44qj
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-613
Updated
2026-11-02
NVD 6.5

Insufficient Session Expiration in GitHub repository pyload/pyload prior to 0.5.0b3.dev36.

Record
CVE-2023-0227
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
Weakness
CWE-613
Updated
2026-11-02
OSV 8.3

Insufficient Session Expiration in pyload/pyload

Insufficient Session Expiration in GitHub repository pyload/pyload prior to 0.5.0b3.dev36.

Record
CVE-2023-0227
CVSS 3.0
8.3 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
Weakness
CWE-613
Updated
2026-11-02
OSVGHSA-rv9x-wmw4-44qj 6.5

Pyload Insufficient Session Expiration vulnerability

Pyload 0.5.0b3.dev35 has an Insufficient Session Expiration vulnerability. A patch is available and anticipated to be part of version 0.5.0b3.dev36.

Record
GHSA-rv9x-wmw4-44qj
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-613
Updated
2026-11-02
OSVPYSEC-2026-906 6.5

Pyload Insufficient Session Expiration vulnerability

Pyload 0.5.0b3.dev35 has an Insufficient Session Expiration vulnerability. A patch is available and anticipated to be part of version 0.5.0b3.dev36.

Record
PYSEC-2026-906
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pyload-ng
PyPI
through 0.5.0b3.dev35
0.5.0b3.dev36
pyload-ng
PyPI
before 0.5.0b3.dev36, plus listed versions
0.5.0a5.dev5280.5.0a5.dev5320.5.0a5.dev5350.5.0a5.dev5360.5.0a5.dev537
Show 45 moreShow less
0.5.0a5.dev5390.5.0a5.dev5400.5.0a5.dev5450.5.0a5.dev5620.5.0a5.dev5640.5.0a5.dev5650.5.0a6.dev5700.5.0a6.dev5780.5.0a6.dev5870.5.0a7.dev5960.5.0a8.dev6020.5.0a9.dev6150.5.0a9.dev6290.5.0a9.dev6320.5.0a9.dev6410.5.0a9.dev6430.5.0a9.dev6550.5.0a9.dev8060.5.0b1.dev10.5.0b1.dev20.5.0b1.dev30.5.0b1.dev40.5.0b1.dev50.5.0b2.dev100.5.0b2.dev110.5.0b2.dev120.5.0b2.dev90.5.0b3.dev130.5.0b3.dev140.5.0b3.dev170.5.0b3.dev180.5.0b3.dev190.5.0b3.dev200.5.0b3.dev210.5.0b3.dev220.5.0b3.dev240.5.0b3.dev260.5.0b3.dev270.5.0b3.dev280.5.0b3.dev290.5.0b3.dev300.5.0b3.dev310.5.0b3.dev320.5.0b3.dev330.5.0b3.dev34
0.5.0b3.dev36

History

History
WhenChangedSources
2026-11-02createdCVE List, EUVD, GitHub Advisories, NVD, OSV

References

This page doesn't list everything

Left out here: 1 version. The JSON record has them.

MoveEnter Open