CVE-2023-0298
Incorrect Authorization in firefly-iii/firefly-iii
Incorrect Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Incorrect Authorization in firefly-iii/firefly-iii
Incorrect Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.
- Record
CVE-2023-0298- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
EUVDEUVD-2023-0390
6.5
Incorrect Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.
- Record
EUVD-2023-0390- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-7mc4-jp4f-v2j2
6.5
Improper Authorization in grumpydictator/firefly-iii
Improper Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.
- Record
GHSA-7mc4-jp4f-v2j2- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
NVD
6.5
Incorrect Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.
- Record
CVE-2023-0298- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
OSV
6.5
Incorrect Authorization in firefly-iii/firefly-iii
Incorrect Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.
- Record
CVE-2023-0298- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
OSVGHSA-7mc4-jp4f-v2j2
6.5
Improper Authorization in grumpydictator/firefly-iii
Improper Authorization in GitHub repository firefly-iii/firefly-iii prior to 5.8.0.
- Record
GHSA-7mc4-jp4f-v2j2- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
grumpydictator/firefly-iiiPackagist |
before 5.8.0 | 5.8.0 |
grumpydictator/firefly-iiiPackagist |
before 5.8.0, plus listed versions 3.0.03.0.13.0.23.0.33.1 Show 45 moreShow less3.1.13.1.23.1.33.1.43.1.53.1.63.103.10.13.10.23.10.33.10.43.2.03.2.13.2.23.2.33.2.43.2.53.33.3.13.3.23.3.33.3.43.3.53.3.63.3.73.3.83.3.93.43.4.0.13.4.0.103.4.0.23.4.0.33.4.0.43.4.0.53.4.0.63.4.0.73.4.0.83.4.0.93.4.13.4.103.4.113.4.23.4.33.4.43.4.4.1 |
5.8.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-0298 is a medium vulnerability (CVSS 6.5) in Firefly-iii Firefly-iii/firefly-iii, published January 14, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.64%, the 51st percentile. Fixed in grumpydictator/firefly-iii 5.8.0.
References
huntr.dev/bounties/9689052c-c1d7-4aae-aa08-346c9b6e04ed
github.com/firefly-iii/firefly-iii/commit/db0500dcf0d4f1990fc7a377ef0d56c3884fcaa4
nvd.nist.gov/vuln/detail/CVE-2023-0298
github.com/advisories/GHSA-7mc4-jp4f-v2j2
github.com/CVEProject/cvelistV5/tree/main/cves/2023/0xxx/CVE-2023-0298.json
github.com/firefly-iii/firefly-iii
Left out here: 233 versions. The JSON record has them.