CVE-2023-0734
Improper Authorization in wallabag/wallabag
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.4.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.3
Improper Authorization in wallabag/wallabag
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.4.
- Record
CVE-2023-0734- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2023-0943
7.3
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.4.
- Record
EUVD-2023-0943- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8ccw-f83g-v7g3
5.3
Wallabag Improper Authorization vulnerability
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.4.
- Record
GHSA-8ccw-f83g-v7g3- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
NVD
5.3
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.4.
- Record
CVE-2023-0734- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-285
- Updated
- 2026-11-02
OSV
7.3
Improper Authorization in wallabag/wallabag
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.4.
- Record
CVE-2023-0734- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGHSA-8ccw-f83g-v7g3
5.3
Wallabag Improper Authorization vulnerability
Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.4.
- Record
GHSA-8ccw-f83g-v7g3- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wallabag/wallabagPackagist |
before 2.5.4 | 2.5.4 |
wallabag/wallabagPackagist |
before 2.5.4, plus listed versions 1.0-beta11.0-beta21.0-beta31.0-beta41.0-beta5 Show 45 moreShow less1.0-beta5.11.0-beta5.21.0.01.1.01.2.01.3.01.3.11.4.01.5.01.5.11.5.1.11.5.21.6.01.6.11.6.1b1.7.01.7.11.7.21.8.01.8.11.8.1b1.91.9.11.9.1-b1.9.1alpha11.9.1alpha21.9.1beta11.9.1beta21.9.1beta31.9.21.9RC11.9beta1.9beta22.0.02.0.0-alpha.02.0.0-alpha.12.0.0-alpha.22.0.0-beta.12.0.0-beta.22.0.12.0.22.0.32.0.42.0.52.0.6 |
2.5.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-0734 is a high vulnerability (CVSS 7.3) in Wallabag, published March 5, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.50%, the 42nd percentile. Fixed in wallabag/wallabag 2.5.4.
References
huntr.dev/bounties/a296324c-6925-4f5f-a729-39b0d73d5b8b
github.com/wallabag/wallabag/commit/acd285dcbb71b595e6320bb1d0d3a44cdf646ac0
nvd.nist.gov/vuln/detail/CVE-2023-0734
github.com/wallabag/wallabag/releases/tag/2.5.4
github.com/advisories/GHSA-8ccw-f83g-v7g3
github.com/CVEProject/cvelistV5/tree/main/cves/2023/0xxx/CVE-2023-0734.json
github.com/wallabag/wallabag
Left out here: 31 versions. The JSON record has them.