CVE-2023-1237
Cross-site Scripting (XSS) - Stored in answerdev/answer
CVE-2023-1237 is a low vulnerability (CVSS 3.4) in Answer, published March 7, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in github.com/answerdev/answer 1.0.6.
Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
3.4
Cross-site Scripting (XSS) - Stored in answerdev/answer
Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.
- Record
CVE-2023-1237- CVSS 3.0
- 3.4 Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2023-0973
3.4
Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.
- Record
EUVD-2023-0973- CVSS 3.0
- 3.4 Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9v4v-9fj5-p982
5.4
Answer vulnerable to Cross-site Scripting
Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.
- Record
GHSA-9v4v-9fj5-p982- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.4
Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.
- Record
CVE-2023-1237- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 3.0
- 3.4 Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
3.4
Cross-site Scripting (XSS) - Stored in answerdev/answer
Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.
- Record
CVE-2023-1237- CVSS 3.0
- 3.4 Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-9v4v-9fj5-p982
5.4
Answer vulnerable to Cross-site Scripting
Cross-site Scripting (XSS) - Stored in GitHub repository answerdev/answer prior to 1.0.6.
- Record
GHSA-9v4v-9fj5-p982- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGO-2023-1616 No score
Answer vulnerable to Cross-site Scripting in github.com/answerdev/answer
Answer vulnerable to Cross-site Scripting in github.com/answerdev/answer
- Record
GO-2023-1616- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/answerdev/answerGo |
before 1.0.6 | 1.0.6 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-02 | created | CVE List, EUVD, GitHub Advisories, NVD, OSV |
References
github.com/answerdev/answer/commit/0566894a2c0e13cf07d877f41467e2e21529fee8
huntr.dev/bounties/cc2aa618-05da-495d-a5cd-51c40557d481
nvd.nist.gov/vuln/detail/CVE-2023-1237
github.com/advisories/GHSA-9v4v-9fj5-p982
github.com/CVEProject/cvelistV5/tree/main/cves/2023/1xxx/CVE-2023-1237.json
github.com/answerdev/answer