CVE-2023-1326
local privilege escalation in apport-cli
A privilege escalation attack was found in apport-cli 2.26.0 and earlier which is similar to CVE-2023-26604. If a system is specially configured to allow unprivileged users to run sudo apport-cli, less is configured as the pager, and the terminal size can be set: a local attacker can escalate privilege. It is extremely unlikely that a system administrator would configure sudo to allow unprivileged users to perform this class of exploit.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.7
local privilege escalation in apport-cli
A privilege escalation attack was found in apport-cli 2.26.0 and earlier which is similar to CVE-2023-26604. If a system is specially configured to allow unprivileged users to run sudo apport-cli, less is configured as the pager, and the terminal size can be set: a local attacker can escalate privilege. It is extremely unlikely that a system administrator would configure sudo to allow unprivileged users to perform this class of exploit.
- Record
CVE-2023-1326- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
EUVDEUVD-2023-23584
7.7
A privilege escalation attack was found in apport-cli 2.26.0 and earlier which is similar to CVE-2023-26604. If a system is specially configured to allow unprivileged users to run sudo apport-cli, less is configured as the pager, and the terminal size can be set: a local attacker can escalate privilege. It is extremely unlikely that a system administrator would configure sudo to allow unprivileged users to perform this class of exploit.
- Record
EUVD-2023-23584- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qgrc-7333-5cgx
7.7
A privilege escalation attack was found in apport-cli 2.26.0 and earlier which is similar to CVE...
A privilege escalation attack was found in apport-cli 2.26.0 and earlier which is similar to CVE-2023-26604. If a system is specially configured to allow unprivileged users to run sudo apport-cli, less is configured as the pager, and the terminal size can be set: a local attacker can escalate privilege. It is extremely unlikely that a system administrator would configure sudo to allow unprivileged users to perform this class of exploit.
- Record
GHSA-qgrc-7333-5cgx- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
NVD
7.7
A privilege escalation attack was found in apport-cli 2.26.0 and earlier which is similar to CVE-2023-26604. If a system is specially configured to allow unprivileged users to run sudo apport-cli, less is configured as the pager, and the terminal size can be set: a local attacker can escalate privilege. It is extremely unlikely that a system administrator would configure sudo to allow unprivileged users to perform this class of exploit.
- Record
CVE-2023-1326- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSV
7.7
local privilege escalation in apport-cli
A privilege escalation attack was found in apport-cli 2.26.0 and earlier which is similar to CVE-2023-26604. If a system is specially configured to allow unprivileged users to run sudo apport-cli, less is configured as the pager, and the terminal size can be set: a local attacker can escalate privilege. It is extremely unlikely that a system administrator would configure sudo to allow unprivileged users to perform this class of exploit.
- Record
CVE-2023-1326- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-1326
7.8
A privilege escalation attack was found in apport-cli 2.26.0 and earlier which is similar to CVE-2023-26604. If a system is specially configured to allow unprivileged users to run sudo apport-cli, less is configured as the pager, and the terminal size can be set: a local attacker can escalate privilege. It is extremely unlikely that a system administrator would configure sudo to allow unprivileged users to perform this class of exploit.
- Record
UBUNTU-CVE-2023-1326- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.7 High
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-6018-1 No score
apport vulnerability
Chen Lu, Lei Wang, and YiQi Sun discovered a privilege escalation vulnerability in apport-cli when viewing crash reports and unprivileged users are allowed to run sudo less. A local attacker on a specially configured system could use this to escalate their privilege.
- Record
USN-6018-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apportUbuntu:18.04:LTS |
before 2.20.9-0ubuntu7.29, plus listed versions 2.20.7-0ubuntu32.20.7-0ubuntu3.12.20.7-0ubuntu42.20.8-0ubuntu12.20.8-0ubuntu2 Show 39 moreShow less2.20.8-0ubuntu32.20.8-0ubuntu42.20.8-0ubuntu52.20.8-0ubuntu62.20.8-0ubuntu72.20.8-0ubuntu82.20.8-0ubuntu92.20.8-0ubuntu102.20.9-0ubuntu12.20.9-0ubuntu22.20.9-0ubuntu42.20.9-0ubuntu52.20.9-0ubuntu62.20.9-0ubuntu72.20.9-0ubuntu7.12.20.9-0ubuntu7.22.20.9-0ubuntu7.32.20.9-0ubuntu7.42.20.9-0ubuntu7.52.20.9-0ubuntu7.62.20.9-0ubuntu7.72.20.9-0ubuntu7.82.20.9-0ubuntu7.92.20.9-0ubuntu7.112.20.9-0ubuntu7.122.20.9-0ubuntu7.132.20.9-0ubuntu7.142.20.9-0ubuntu7.152.20.9-0ubuntu7.162.20.9-0ubuntu7.172.20.9-0ubuntu7.182.20.9-0ubuntu7.192.20.9-0ubuntu7.202.20.9-0ubuntu7.212.20.9-0ubuntu7.232.20.9-0ubuntu7.242.20.9-0ubuntu7.262.20.9-0ubuntu7.272.20.9-0ubuntu7.28 |
2.20.9-0ubuntu7.29 |
apportUbuntu:20.04:LTS |
before 2.20.11-0ubuntu27.26, plus listed versions 2.20.11-0ubuntu82.20.11-0ubuntu92.20.11-0ubuntu132.20.11-0ubuntu142.20.11-0ubuntu15 Show 30 moreShow less2.20.11-0ubuntu162.20.11-0ubuntu172.20.11-0ubuntu182.20.11-0ubuntu192.20.11-0ubuntu202.20.11-0ubuntu212.20.11-0ubuntu222.20.11-0ubuntu242.20.11-0ubuntu252.20.11-0ubuntu262.20.11-0ubuntu272.20.11-0ubuntu27.22.20.11-0ubuntu27.32.20.11-0ubuntu27.42.20.11-0ubuntu27.62.20.11-0ubuntu27.82.20.11-0ubuntu27.92.20.11-0ubuntu27.102.20.11-0ubuntu27.112.20.11-0ubuntu27.122.20.11-0ubuntu27.132.20.11-0ubuntu27.142.20.11-0ubuntu27.162.20.11-0ubuntu27.172.20.11-0ubuntu27.182.20.11-0ubuntu27.202.20.11-0ubuntu27.212.20.11-0ubuntu27.232.20.11-0ubuntu27.242.20.11-0ubuntu27.25 |
2.20.11-0ubuntu27.26 |
apportUbuntu:22.04:LTS |
before 2.20.11-0ubuntu82.4, plus listed versions 2.20.11-0ubuntu702.20.11-0ubuntu732.20.11-0ubuntu742.20.11-0ubuntu752.20.11-0ubuntu76 Show 9 moreShow less2.20.11-0ubuntu772.20.11-0ubuntu782.20.11-0ubuntu792.20.11-0ubuntu802.20.11-0ubuntu812.20.11-0ubuntu822.20.11-0ubuntu82.12.20.11-0ubuntu82.22.20.11-0ubuntu82.3 |
2.20.11-0ubuntu82.4 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | Pol-Ruiz/CVE-2023-1326 | 2024-01-16 |
| PoC in GitHub | R3fr4kt/DEVVORTEX | 2026-09-12 |
| PoC in GitHub | cve-2024/CVE-2023-1326-PoC | 2024-06-14 |
| PoC in GitHub | diego-tella/CVE-2023-1326-PoC | 2023-12-06 |
| PoC in GitHub | h3x0v3rl0rd/CVE-2023-1326 | 2024-05-04 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-1326 is a high vulnerability (CVSS 7.7) in Canonical Apport, published April 13, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.88%, the 59th percentile. Fixed in apport 2.20.9-0ubuntu7.29.