Every CVE Search/ Get API key

CVE-2023-1355

NULL Pointer Dereference in vim/vim

8.4 HighFix available

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.45%Up 0.4 points since Mar 12, 2023
90%50%10%1%

What each source reports

CVE List Score used 8.4

NULL Pointer Dereference in vim/vim

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

Record
CVE-2023-1355
CVSS 3.0
8.4 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-476
Updated
2026-11-02
EUVDEUVD-2023-23613 8.4

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

Record
EUVD-2023-23613
CVSS 3.0
8.4 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-cr28-mcq5-hjmg 7.5

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

Record
GHSA-cr28-mcq5-hjmg
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
NVD 5.5

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

Record
CVE-2023-1355
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 3.0
8.4 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-476
Updated
2026-11-02
OSVALPINE-CVE-2023-1355 5.5

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

Record
ALPINE-CVE-2023-1355
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVBELL-CVE-2023-1355 5.5
Record
BELL-CVE-2023-1355
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSV 8.4

NULL Pointer Dereference in vim/vim

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

Record
CVE-2023-1355
CVSS 3.0
8.4 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-476
Updated
2026-11-02
OSVDEBIAN-CVE-2023-1355 5.5

NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.

Record
DEBIAN-CVE-2023-1355
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:12832-1 No score

gvim-9.0.1430-1.1 on GA media

These are all security issues fixed in the gvim-9.0.1430-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12832-1
Updated
2026-11-02
OSVSUSE-SU-2023:2103-1 No score

Security update for vim

This update for vim fixes the following issues:

Updated to version 9.0 with patch level 1443, fixes the following security problems

  • CVE-2023-1264: Fixed NULL Pointer Dereference (bsc#1209042).
  • CVE-2023-1355: Fixed NULL Pointer Dereference (bsc#1209187).
  • CVE-2023-1127: Fixed divide by zero in scrolldown() (bsc#1208828).
Record
SUSE-SU-2023:2103-1
Updated
2026-11-02
OSVSUSE-SU-2023:3463-1 No score

Security update for vim

This update for vim fixes the following issues:

Updated to version 9.0 with patch level 1572.

  • CVE-2023-2426: Fixed Out-of-range Pointer Offset use (bsc#1210996).
  • CVE-2023-2609: Fixed NULL Pointer Dereference (bsc#1211256).
  • CVE-2023-2610: Fixed nteger Overflow or Wraparound (bsc#1211257).
  • CVE-2023-1264: Fixed NULL Pointer Dereference (bsc#1209042).
  • CVE-2023-1355: Fixed NULL Pointer Dereference (bsc#1209187).
  • CVE-2023-1127: Fixed divide by zero in scrolldown() (bsc#1208828).
Record
SUSE-SU-2023:3463-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vim
Alpine:v3.18
before 9.0.1395-r0
9.0.1395-r0
vim
Alpine:v3.19
before 9.0.1395-r0
9.0.1395-r0
vim
Alpine:v3.20
before 9.0.1395-r0
9.0.1395-r0
vim
Alpine:v3.21
before 9.0.1395-r0
9.0.1395-r0
vim
Alpine:v3.22
before 9.0.1395-r0
9.0.1395-r0
vim
Alpine:v3.23
before 9.0.1395-r0
9.0.1395-r0
vim
Alpine:v3.24
before 9.0.1395-r0
9.0.1395-r0
vim
Alpaquita:23
9.0.0820-r2 up to 9.1.0936-r0
9.1.0936-r0
vim
Debian:12
All versions, plus listed versions
2:9.0.1378-22:9.0.1378-2+deb12u12:9.0.1378-2+deb12u22:9.0.1658-12:9.0.1672-1
Show 40 moreShow less
2:9.0.1894-12:9.0.2018-12:9.0.2087-12:9.0.2103-12:9.0.2116-12:9.0.2189-12:9.1.0-12:9.1.0016-12:9.1.0199-12:9.1.0374-12:9.1.0377-12:9.1.0496-12:9.1.0698-12:9.1.0709-12:9.1.0709-22:9.1.0777-12:9.1.0861-12:9.1.0967-12:9.1.0967-22:9.1.1113-12:9.1.1230-12:9.1.1230-22:9.1.1385-12:9.1.1766-12:9.1.1829-12:9.1.1846-12:9.1.1882-12:9.1.2103-12:9.1.2141-12:9.2.0119-12:9.2.0136-12:9.2.0218-12:9.2.0315-12:9.2.0338-12:9.2.0355-12:9.2.0428-12:9.2.0461-12:9.2.0524-12:9.2.0782-12:9.2.0858-1
None known
vim
Debian:13
before 2:9.0.1658-1
2:9.0.1658-1
Show 14 moreShow less
Affected packages
PackageAffectedFixed
vim
Debian:14
before 2:9.0.1658-1
2:9.0.1658-1
vim
SUSE:Linux Enterprise Micro 5.3
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
SUSE:Linux Enterprise Micro 5.4
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
SUSE:Linux Enterprise Module for Basesystem 15 SP4
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
SUSE:Linux Enterprise Real Time 15 SP3
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
SUSE:Linux Enterprise Micro 5.1
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
SUSE:Linux Enterprise Micro 5.2
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
openSUSE:Leap Micro 5.3
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
openSUSE:Leap 15.4
From an advisory covering 3 CVEs
before 9.0.1443-150000.5.40.1
9.0.1443-150000.5.40.1
vim
SUSE:Linux Enterprise Server 12 SP2-BCL
From an advisory covering 6 CVEs
before 9.0.1572-17.18.1
9.0.1572-17.18.1
vim
SUSE:Linux Enterprise Server 12 SP5
From an advisory covering 6 CVEs
before 9.0.1572-17.18.1
9.0.1572-17.18.1
vim
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
From an advisory covering 6 CVEs
before 9.0.1572-17.18.1
9.0.1572-17.18.1
vim
openSUSE:Tumbleweed
before 9.0.1430-1.1
9.0.1430-1.1

History

History
RecordedChangedSources
affected, facts
affectedOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-1355 is a high vulnerability (CVSS 8.4) in Vim, published March 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.45%, the 39th percentile. Fixed in vim 9.0.1395-r0.

References

Show 18 moreShow less
MoveEnter Open