CVE-2023-1543
Insufficient Session Expiration in answerdev/answer
Insufficient Session Expiration in GitHub repository answerdev/answer prior to 1.0.6.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.8
Insufficient Session Expiration in answerdev/answer
Insufficient Session Expiration in GitHub repository answerdev/answer prior to 1.0.6.
- Record
CVE-2023-1543- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
EUVDEUVD-2023-0920
6.8
Insufficient Session Expiration in GitHub repository answerdev/answer prior to 1.0.6.
- Record
EUVD-2023-0920- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-79hx-g43v-xfmr
8.8
Answer vulnerable to Insufficient Session Expiration
Insufficient Session Expiration in GitHub repository answerdev/answer prior to 1.0.6.
- Record
GHSA-79hx-g43v-xfmr- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
NVD
8.8
Insufficient Session Expiration in GitHub repository answerdev/answer prior to 1.0.6.
- Record
CVE-2023-1543- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
OSV
6.8
Insufficient Session Expiration in answerdev/answer
Insufficient Session Expiration in GitHub repository answerdev/answer prior to 1.0.6.
- Record
CVE-2023-1543- CVSS 3.0
- 6.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
OSVGHSA-79hx-g43v-xfmr
8.8
Answer vulnerable to Insufficient Session Expiration
Insufficient Session Expiration in GitHub repository answerdev/answer prior to 1.0.6.
- Record
GHSA-79hx-g43v-xfmr- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
OSVGO-2023-1655 No score
Answer vulnerable to Insufficient Session Expiration in github.com/answerdev/answer
Answer vulnerable to Insufficient Session Expiration in github.com/answerdev/answer
- Record
GO-2023-1655- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/answerdev/answerGo |
before 1.0.6 | 1.0.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-1543 is a medium vulnerability (CVSS 6.8) in Answer, published March 21, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.78%, the 55th percentile. Fixed in github.com/answerdev/answer 1.0.6.
References
huntr.dev/bounties/f82388d6-dfc3-4fbc-bea6-eb40cf5b2683
github.com/answerdev/answer/commit/cd742b75605c99776f32d271c0a60e0f468e181c
nvd.nist.gov/vuln/detail/CVE-2023-1543
github.com/advisories/GHSA-79hx-g43v-xfmr
github.com/CVEProject/cvelistV5/tree/main/cves/2023/1xxx/CVE-2023-1543.json
github.com/answerdev/answer