Every CVE Search/ Get API key

CVE-2023-1788

Insufficient Session Expiration in firefly-iii/firefly-iii

5.4 MediumFix available

Insufficient Session Expiration in GitHub repository firefly-iii/firefly-iii prior to 6.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.44%Up 0.4 points since Apr 6, 2023
90%50%10%1%

What each source reports

CVE List Score used 5.4

Insufficient Session Expiration in firefly-iii/firefly-iii

Insufficient Session Expiration in GitHub repository firefly-iii/firefly-iii prior to 6.

Record
CVE-2023-1788
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-613
Updated
2026-11-02
EUVDEUVD-2023-1319 5.4

Insufficient Session Expiration in GitHub repository firefly-iii/firefly-iii prior to 6.

Record
EUVD-2023-1319
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-h7vv-46p5-prmh 4.2

Firefly III insufficiently expires sessions

Firefly III prior to 6.0.0 insufficiently expires sessions upon close.

Record
GHSA-h7vv-46p5-prmh
CVSS 3.1
4.2 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-613
Updated
2026-11-02
NVD 9.8

Insufficient Session Expiration in GitHub repository firefly-iii/firefly-iii prior to 6.

Record
CVE-2023-1788
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-613
Updated
2026-11-02
OSV 5.4

Insufficient Session Expiration in firefly-iii/firefly-iii

Insufficient Session Expiration in GitHub repository firefly-iii/firefly-iii prior to 6.

Record
CVE-2023-1788
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-613
Updated
2026-11-02
OSVGHSA-h7vv-46p5-prmh 4.2

Firefly III insufficiently expires sessions

Firefly III prior to 6.0.0 insufficiently expires sessions upon close.

Record
GHSA-h7vv-46p5-prmh
CVSS 3.1
4.2 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-613
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
grumpydictator/firefly-iii
Packagist
before 6.0.0
6.0.0
grumpydictator/firefly-iii
Packagist
before 6.0.0, plus listed versions
3.0.03.0.13.0.23.0.33.1
Show 45 moreShow less
3.1.13.1.23.1.33.1.43.1.53.1.63.103.10.13.10.23.10.33.10.43.2.03.2.13.2.23.2.33.2.43.2.53.33.3.13.3.23.3.33.3.43.3.53.3.63.3.73.3.83.3.93.43.4.0.13.4.0.103.4.0.23.4.0.33.4.0.43.4.0.53.4.0.63.4.0.73.4.0.83.4.0.93.4.13.4.103.4.113.4.23.4.33.4.43.4.4.1
6.0.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-1788 is a medium vulnerability (CVSS 5.4) in Firefly-iii Firefly-iii/firefly-iii, published April 5, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in grumpydictator/firefly-iii 6.0.0.

References

This page doesn't list everything

Left out here: 237 versions. The JSON record has them.

MoveEnter Open