Every CVE Search/ Get API key

CVE-2023-2014

Cross-site Scripting (XSS) - Generic in microweber/microweber

5.3 MediumFix available

Cross-site Scripting (XSS) - Generic in GitHub repository microweber/microweber prior to 1.3.3.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
Low
Availability
Low

Exploit likelihood

0.48%Up 0.4 points since Apr 15, 2023
90%50%10%1%

What each source reports

CVE List Score used 5.3

Cross-site Scripting (XSS) - Generic in microweber/microweber

Cross-site Scripting (XSS) - Generic in GitHub repository microweber/microweber prior to 1.3.3.

Record
CVE-2023-2014
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2023-1277 5.3

Cross-site Scripting (XSS) - Generic in GitHub repository microweber/microweber prior to 1.3.3.

Record
EUVD-2023-1277
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-f4g6-c47x-qhww 4.8

Microweber vulnerable to cross-site scripting (XSS)

microweber/microweber prior to 1.3.3 is vulnerable to cross-site scripting (XSS) in the template selection while changing a group template.

Record
GHSA-f4g6-c47x-qhww
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 4.8

Cross-site Scripting (XSS) - Generic in GitHub repository microweber/microweber prior to 1.3.3.

Record
CVE-2023-2014
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
OSV 5.3

Cross-site Scripting (XSS) - Generic in microweber/microweber

Cross-site Scripting (XSS) - Generic in GitHub repository microweber/microweber prior to 1.3.3.

Record
CVE-2023-2014
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-f4g6-c47x-qhww 4.8

Microweber vulnerable to cross-site scripting (XSS)

microweber/microweber prior to 1.3.3 is vulnerable to cross-site scripting (XSS) in the template selection while changing a group template.

Record
GHSA-f4g6-c47x-qhww
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
microweber/microweber
Packagist
before 1.3.3
1.3.3
microweber/microweber
Packagist
before 1.3.3, plus listed versions
0.9.3460.930.9310.9340.951
Show 28 moreShow less
1.0.31.0.41.0.51.0.61.0.71.1v1.2.10v1.2.11v1.2.12v1.2.13v1.2.14v1.2.15v1.2.16v1.2.17v1.2.18v1.2.19v1.2.20v1.2.21v1.2.3v1.2.4v1.2.5v1.2.6v1.2.7v1.2.8v1.2.9v1.3.0v1.3.1v1.3.2
1.3.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-2014 is a medium vulnerability (CVSS 5.3) in Microweber, published April 13, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 41st percentile. Fixed in microweber/microweber 1.3.3.

References

MoveEnter Open