Every CVE Search/ Get API key

CVE-2023-2160

Weak Password Requirements in modoboa/modoboa

6.3 MediumFix available

CVE-2023-2160 is a medium vulnerability (CVSS 6.3) in Modoboa, published April 18, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 49th percentile. Fixed in modoboa 2.1.0.

Weak Password Requirements in GitHub repository modoboa/modoboa prior to 2.1.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.62%Up 0.6 points since Apr 19, 2023
90%50%10%1%

What each source reports

CVE List Score used 6.3

Weak Password Requirements in modoboa/modoboa

Weak Password Requirements in GitHub repository modoboa/modoboa prior to 2.1.0.

Record
CVE-2023-2160
CVSS 3.1
6.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-521
Updated
2026-11-02
EUVDEUVD-2023-0170 6.3

Weak Password Requirements in GitHub repository modoboa/modoboa prior to 2.1.0.

Record
EUVD-2023-0170
CVSS 3.1
6.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-9gxx-32p7-ff7m 5.3

Modoboa has Weak Password Requirements

Modoboa 2.0.5 and prior allows users to set unsafe passwords, such as 1 or HACK. This issue is fixed in commit 130257c96a2392ada795785a91178e656e27015c and is part of version 2.1.0.

Record
GHSA-9gxx-32p7-ff7m
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-521
Updated
2026-11-02
NVD 6.3

Weak Password Requirements in GitHub repository modoboa/modoboa prior to 2.1.0.

Record
CVE-2023-2160
CVSS 3.1
6.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-521
Updated
2026-11-02
OSV 6.3

Weak Password Requirements in modoboa/modoboa

Weak Password Requirements in GitHub repository modoboa/modoboa prior to 2.1.0.

Record
CVE-2023-2160
CVSS 3.1
6.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-521
Updated
2026-11-02
OSVGHSA-9gxx-32p7-ff7m 5.3

Modoboa has Weak Password Requirements

Modoboa 2.0.5 and prior allows users to set unsafe passwords, such as 1 or HACK. This issue is fixed in commit 130257c96a2392ada795785a91178e656e27015c and is part of version 2.1.0.

Record
GHSA-9gxx-32p7-ff7m
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-521
Updated
2026-11-02
OSVPYSEC-2023-34 No score

Weak Password Requirements in GitHub repository modoboa/modoboa prior to 2.1.0.

Record
PYSEC-2023-34
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
modoboa
PyPI
through 2.0.5
2.1.0
modoboa
PyPI
before 2.1.0, plus listed versions
0.7.01.10.01.10.11.10.21.10.3
Show 45 moreShow less
1.10.41.10.51.10.61.10.71.11.01.11.11.12.01.12.11.12.21.13.01.13.11.14.01.15.01.16.01.16.11.17.01.2.01.2.0-rc21.2.11.2.21.3.01.3.11.3.21.3.31.3.41.3.51.4.11.4.21.4.31.4.41.4.51.5.01.5.11.5.21.5.31.6.01.6.11.6.21.6.31.7.01.7.11.7.21.7.31.7.41.8.0
2.1.0
modoboa
PyPI
before 2.1.0, plus listed versions
0.7.01.10.01.10.11.10.21.10.3
Show 45 moreShow less
1.10.41.10.51.10.61.10.71.11.01.11.11.12.01.12.11.12.21.13.01.13.11.14.01.15.01.16.01.16.11.17.01.2.01.2.0-rc21.2.11.2.21.3.01.3.11.3.21.3.31.3.41.3.51.4.11.4.21.4.31.4.41.4.51.5.01.5.11.5.21.5.31.6.01.6.11.6.21.6.31.7.01.7.11.7.21.7.31.7.41.8.0
2.1.0

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

This page doesn't list everything

Left out here: 61 versions. The JSON record has them.

MoveEnter Open