CVE-2023-22298
pgAdmin 4 Open Redirect vulnerability
Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.
- Record
CVE-2023-22298- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-601
- Updated
- 2026-11-02
CVE List
6.1
Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.
- Record
CVE-2023-22298- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-601
- Updated
- 2026-11-02
EUVDEUVD-2023-0402
6.1
Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.
- Record
EUVD-2023-0402- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-894c-rg7f-3c62
6.1
pgAdmin 4 Open Redirect vulnerability
Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.
- Record
GHSA-894c-rg7f-3c62- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-601
- Updated
- 2026-11-02
OSV
6.1
Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.
- Record
CVE-2023-22298- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-894c-rg7f-3c62
6.1
pgAdmin 4 Open Redirect vulnerability
Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.
- Record
GHSA-894c-rg7f-3c62- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-601
- Updated
- 2026-11-02
OSVPYSEC-2026-894
6.1
pgAdmin 4 Open Redirect vulnerability
Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.
- Record
PYSEC-2026-894- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13667-1 No score
pgadmin4-8.2-1.1 on GA media
These are all security issues fixed in the pgadmin4-8.2-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13667-1- Updated
- 2026-11-02
OSVSUSE-SU-2023:1739-1 No score
Security update for pgadmin4
This update for pgadmin4 fixes the following issues:
- CVE-2023-22298: Fixed an open redirect vulnerability (bsc#1207238).
- Record
SUSE-SU-2023:1739-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pgadmin4PyPI |
before 6.14 | 6.14 |
pgadmin4PyPI |
before 6.14, plus listed versions 4.204.224.234.244.25 Show 25 moreShow less4.264.274.284.294.305.05.15.25.35.45.55.65.76.106.116.126.136.26.36.46.56.66.76.86.9 |
6.14 |
pgadmin4SUSE:Linux Enterprise Module for Server Applications 15 SP4 |
before 4.30-150300.3.6.1 | 4.30-150300.3.6.1 |
pgadmin4SUSE:Linux Enterprise Real Time 15 SP3 |
before 4.30-150300.3.6.1 | 4.30-150300.3.6.1 |
pgadmin4openSUSE:Leap 15.4 |
before 4.30-150300.3.6.1 | 4.30-150300.3.6.1 |
pgadmin4openSUSE:Tumbleweed From an advisory covering 3 CVEs |
before 8.2-1.1 | 8.2-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-22298 is a medium vulnerability (CVSS 6.1) in Pgadmin 4, published January 17, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.96%, the 61st percentile. Fixed in pgadmin4 6.14.
References
pgadmin.org
github.com/pgadmin-org/pgadmin4
github.com/pgadmin-org/pgadmin4/issues/5343
jvn.jp/en/jp/JVN03832974/index.html
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VHY2B25YHIIFQ3G44TR7NNEST7FJGJPH
nvd.nist.gov/vuln/detail/CVE-2023-22298
Show 9 moreShow less
lists.fedoraproject.org/archives/list/[email protected]/message/VHY2B25YHIIFQ3G44TR7NNEST7FJGJPH
github.com/advisories/GHSA-894c-rg7f-3c62
github.com/CVEProject/cvelistV5/tree/main/cves/2023/22xxx/CVE-2023-22298.json
pypi.org/project/pgadmin4
suse.com/support/update/announcement/2023/suse-su-20231739-1
bugzilla.suse.com/1207238
suse.com/security/cve/CVE-2023-22298
suse.com/security/cve/CVE-2022-0959
suse.com/security/cve/CVE-2023-0241