CVE-2023-22665
Apache Jena: Exposure of arbitrary execution in script engine expressions.
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
- Record
CVE-2023-22665- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-917
- Updated
- 2026-11-02
CVE List No score
Apache Jena: Exposure of arbitrary execution in script engine expressions.
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
- Record
CVE-2023-22665- Weakness
- CWE-917
- Updated
- 2026-11-02
EUVDEUVD-2023-1426 No score
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
- Record
EUVD-2023-1426- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xgh5-gwq5-rpx8
5.4
Arbitrary javascript injection in Apache Jena
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
- Record
GHSA-xgh5-gwq5-rpx8- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-917
- Updated
- 2026-11-02
OSV
5.4
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
- Record
CVE-2023-22665- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-22665
5.4
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
- Record
DEBIAN-CVE-2023-22665- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-xgh5-gwq5-rpx8
5.4
Arbitrary javascript injection in Apache Jena
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
- Record
GHSA-xgh5-gwq5-rpx8- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-917
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-22665
5.4
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.
- Record
UBUNTU-CVE-2023-22665- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.jena:jenaMaven |
before 4.8.0 | 4.8.0 |
apache-jenaDebian:12 |
All versions, plus listed versions 4.5.0-24.9.0-1 |
None known |
apache-jenaDebian:13 |
before 4.9.0-1 | 4.9.0-1 |
apache-jenaDebian:14 |
before 4.9.0-1 | 4.9.0-1 |
org.apache.jena:jenaMaven |
before 4.8.0, plus listed versions 2.10.02.10.12.11.02.11.12.11.2 Show 39 moreShow less2.12.02.12.12.13.02.7.12.7.22.7.32.7.43.0.03.0.13.1.03.1.13.10.03.11.03.12.03.13.03.13.13.14.03.15.03.16.03.17.03.2.03.3.03.4.03.5.03.6.03.7.03.8.03.9.04.0.04.1.04.2.04.3.04.3.14.3.24.4.04.5.04.6.04.6.14.7.0 |
4.8.0 |
apache-jenaUbuntu:22.04:LTS |
All versions, plus listed versions 3.17.0-13.17.0-23.17.0-3 |
None known |
apache-jenaUbuntu:24.04:LTS |
All versions, plus listed versions 4.5.0-24.9.0-1 |
None known |
apache-jenaUbuntu:25.10 |
All versions, plus listed versions 4.9.0-1 |
None known |
apache-jenaUbuntu:26.10 |
All versions, plus listed versions 4.9.0-1build1 |
None known |
apache-jenaUbuntu:26.04:LTS |
All versions, plus listed versions 4.9.0-14.9.0-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-22665 is a medium vulnerability (CVSS 5.4) in Apache Jena, published April 25, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.33%, the 71st percentile. Fixed in org.apache.jena:jena 4.8.0.
References
lists.apache.org/thread/s0dmpsxcwqs57l4qfs415klkgmhdxq7s
openwall.com/lists/oss-security/2023/07/11/11
nvd.nist.gov/vuln/detail/CVE-2023-22665
github.com/advisories/GHSA-xgh5-gwq5-rpx8
security-tracker.debian.org/tracker/CVE-2023-22665
github.com/apache/jena
ubuntu.com/security/CVE-2023-22665
cve.org/CVERecord?id=CVE-2023-22665