CVE-2023-22963
personnummer/dart vulnerable to Improper Input Validation
The personnummer implementation before 3.0.3 for Dart mishandles numbers in which the last four digits match the ^000[0-9]$ regular expression.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
The personnummer implementation before 3.0.3 for Dart mishandles numbers in which the last four digits match the ^000[0-9]$ regular expression.
- Record
CVE-2023-22963- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List
5.3
The personnummer implementation before 3.0.3 for Dart mishandles numbers in which the last four digits match the ^000[0-9]$ regular expression.
- Record
CVE-2023-22963- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2022-6699
5.3
The personnummer implementation before 3.0.3 for Dart mishandles numbers in which the last four digits match the ^000[0-9]$ regular expression.
- Record
EUVD-2022-6699- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-4xh4-v2pq-jvhm No score
personnummer/dart vulnerable to Improper Input Validation
This vulnerability was reported to the personnummer team in June 2020. The slow response was due to locked ownership of some of the affected packages, which caused delays to update packages prior to disclosure.
The vulnerability is determined to be low severity.
Impact
This vulnerability impacts users who rely on the for last digits of personnummer to be a real personnummer.
Patches
The issue have been patched in all repositories. The following versions should be updated to as soon as possible:
C# 3.0.2
D 3.0.1
Dart 3.0.3
Elixir 3.0.0
Go 3.0.1
Java 3.3.0
JavaScript 3.1.0
Kotlin 1.1.0
Lua 3.0.1
PHP 3.0.2
Perl 3.0.0
Python 3.0.2
Ruby 3.0.1
Rust 3.0.0
Scala 3.0.1
Swift 1.0.1
If you are using any of the earlier packages, please update to latest.
Workarounds
The issue arrieses from the regular expression allowing the first three digits in the last four digits of the personnummer to be 000, which is invalid. To mitigate this without upgrading, a check on the last four digits can be made to make sure it's not 000x.
For more information
If you have any questions or comments about this advisory:
- Open an issue in Personnummer Meta
- Email us at Personnummer Email
- Record
GHSA-4xh4-v2pq-jvhm- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
5.3
The personnummer implementation before 3.0.3 for Dart mishandles numbers in which the last four digits match the ^000[0-9]$ regular expression.
- Record
CVE-2023-22963- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-4xh4-v2pq-jvhm No score
personnummer/dart vulnerable to Improper Input Validation
This vulnerability was reported to the personnummer team in June 2020. The slow response was due to locked ownership of some of the affected packages, which caused delays to update packages prior to disclosure.
The vulnerability is determined to be low severity.
Impact
This vulnerability impacts users who rely on the for last digits of personnummer to be a real personnummer.
Patches
The issue have been patched in all repositories. The following versions should be updated to as soon as possible:
C# 3.0.2
D 3.0.1
Dart 3.0.3
Elixir 3.0.0
Go 3.0.1
Java 3.3.0
JavaScript 3.1.0
Kotlin 1.1.0
Lua 3.0.1
PHP 3.0.2
Perl 3.0.0
Python 3.0.2
Ruby 3.0.1
Rust 3.0.0
Scala 3.0.1
Swift 1.0.1
If you are using any of the earlier packages, please update to latest.
Workarounds
The issue arrieses from the regular expression allowing the first three digits in the last four digits of the personnummer to be 000, which is invalid. To mitigate this without upgrading, a check on the last four digits can be made to make sure it's not 000x.
For more information
If you have any questions or comments about this advisory:
- Open an issue in Personnummer Meta
- Email us at Personnummer Email
- Record
GHSA-4xh4-v2pq-jvhm- Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
personnummerPub |
before 3.0.3 | 3.0.3 |
personnummerPub |
before 3.0.3, plus listed versions 1.0.01.0.11.0.22.0.02.1.03.0.03.0.13.0.2 |
3.0.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-22963 is a medium vulnerability (CVSS 5.3) in Personnummer, published September 19, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.51%, the 43rd percentile. Fixed in personnummer 3.0.3.