Every CVE Search/ Get API key

CVE-2023-23082

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to...

4.6 MediumFix available

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to cause a denial of service due to an improper length of the value passed to the offset argument.

Attack profile

How easy it is to exploit

Attack vector
Physical
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.68%Down 0.3 points since Feb 4, 2023
90%50%10%1%

What each source reports

NVD Score used 4.6

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to cause a denial of service due to an improper length of the value passed to the offset argument.

Record
CVE-2023-23082
CVSS 3.1
4.6 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to cause a denial of service due to an improper length of the value passed to the offset argument.

Record
CVE-2023-23082
Updated
2026-11-02
EUVDEUVD-2023-27182 No score

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to cause a denial of service due to an improper length of the value passed to the offset argument.

Record
EUVD-2023-27182
Updated
2026-11-03
GitHub AdvisoriesGHSA-xqhf-3qqw-8q2m 4.6

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to...

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to cause a denial of service due to an improper length of the value passed to the offset argument.

Record
GHSA-xqhf-3qqw-8q2m
CVSS 3.1
4.6 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
OSVDEBIAN-CVE-2023-23082 4.6

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to cause a denial of service due to an improper length of the value passed to the offset argument.

Record
DEBIAN-CVE-2023-23082
CVSS 3.1
4.6 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-23082 4.6

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to cause a denial of service due to an improper length of the value passed to the offset argument.

Record
UBUNTU-CVE-2023-23082
CVSS 3.1
4.6 MediumCVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV No score

A heap buffer overflow vulnerability in Kodi Home Theater Software up to 19.5 allows attackers to cause a denial of service due to an improper length of the value passed to the offset argument.

Record
CVE-2023-23082
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kodi
Debian:12
before 2:20.0+dfsg-2
2:20.0+dfsg-2
kodi
Debian:13
before 2:20.0+dfsg-2
2:20.0+dfsg-2
kodi
Debian:14
before 2:20.0+dfsg-2
2:20.0+dfsg-2
kodi
Debian:10
From an advisory covering 4 CVEs
before 2:17.6+dfsg1-4+deb10u1, plus listed versions
2:17.6+dfsg1-4
2:17.6+dfsg1-4+deb10u1
kodi
Debian:11
From an advisory covering 2 CVEs
before 2:19.1+dfsg2-2+deb11u2, plus listed versions
2:19.1+dfsg2-22:19.1+dfsg2-2+deb11u12:19.1+dfsg2-2+deb11u1~bpo10+1
2:19.1+dfsg2-2+deb11u2
kodi
Ubuntu:16.04:LTS
All versions, plus listed versions
15.1+dfsg1-315.2+dfsg1-1build115.2+dfsg1-315.2+dfsg1-3ubuntu115.2+dfsg1-3ubuntu1.1
None known
kodi
Ubuntu:18.04:LTS
All versions, plus listed versions
2:17.3+dfsg1-32:17.3+dfsg1-3build12:17.3+dfsg1-52:17.3+dfsg1-5build12:17.3+dfsg1-5build22:17.6+dfsg1-12:17.6+dfsg1-1build12:17.6+dfsg1-1ubuntu1
None known
kodi
Ubuntu:20.04:LTS
All versions, plus listed versions
2:17.6+dfsg1-4ubuntu42:17.6+dfsg1-4ubuntu92:17.6+dfsg1-4ubuntu102:18.5+dfsg1-0ubuntu32:18.6+dfsg1-2ubuntu1
None known
kodi
Ubuntu:22.04:LTS
All versions, plus listed versions
2:19.1+dfsg2-22:19.3+dfsg1-12:19.3+dfsg1-1build22:19.3+dfsg1-1build32:19.3+dfsg1-1build42:19.3+dfsg1-1build52:19.4+dfsg1-2
None known
kodi
Ubuntu:24.04:LTS
All versions, plus listed versions
2:20.2+dfsg-42:20.2+dfsg-4build12:20.2+dfsg-4build22:20.2+dfsg-4ubuntu12:20.3+dfsg-12:20.4+dfsg-12:20.5+dfsg-1build22:20.5+dfsg-1ubuntu1
None known
kodi
Ubuntu:25.10
All versions, plus listed versions
2:21.2+dfsg-1build22:21.2+dfsg-42:21.2+dfsg-4build12:21.2+dfsg-4build2
None known
kodi
Ubuntu:26.10
All versions, plus listed versions
2:21.3+dfsg-1ubuntu12:21.3+dfsg-1.2
None known
kodi
Ubuntu:26.04:LTS
All versions, plus listed versions
2:21.2+dfsg-4build22:21.2+dfsg-4build32:21.2+dfsg-52:21.3+dfsg-12:21.3+dfsg-1build12:21.3+dfsg-1ubuntu1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-23082 is a medium vulnerability (CVSS 4.6) in Kodi, published February 3, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in kodi 2:20.0+dfsg-2.

References

Show 10 moreShow less
MoveEnter Open