CVE-2023-26140
@excalidraw/excalidraw Cross-site Scripting vulnerability
Versions of the package @excalidraw/excalidraw from 0.0.0 are vulnerable to Cross-site Scripting (XSS) via embedded links in whiteboard objects due to improper input sanitization.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.1
Versions of the package @excalidraw/excalidraw from 0.0.0 are vulnerable to Cross-site Scripting (XSS) via embedded links in whiteboard objects due to improper input sanitization.
- Record
CVE-2023-26140- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:P - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2023-2357
6.1
Versions of the package @excalidraw/excalidraw from 0.0.0 are vulnerable to Cross-site Scripting (XSS) via embedded links in whiteboard objects due to improper input sanitization.
- Record
EUVD-2023-2357- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:P - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v7v8-gjv7-ffmr
6.1
@excalidraw/excalidraw Cross-site Scripting vulnerability
Impact
XSS vulnerability due to improperly sanitizing URLs of links that can be attached on canvas elements. This affects users of the npm package @excalidraw/excalidraw provided it was deployed in environments where untrusted user input in drawings that are then shared with third parties is a concern. If you only hosted the editor in trusted environments, or sharing didn't take place, the impact is minimized.
Patches
Patch is available on version 0.15.3 and up (stable), or latest @excalidraw/excalidraw@next (unstable releases).
Workarounds
No workaround without upgrading unless deployed in environments without untrusted user input.
References
https://security.snyk.io/vuln/SNYK-JS-EXCALIDRAWEXCALIDRAW-5841658 https://github.com/excalidraw/excalidraw/pull/6728
- Record
GHSA-v7v8-gjv7-ffmr- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
6.1
Versions of the package @excalidraw/excalidraw from 0.0.0 are vulnerable to Cross-site Scripting (XSS) via embedded links in whiteboard objects due to improper input sanitization.
- Record
CVE-2023-26140- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Versions of the package @excalidraw/excalidraw from 0.0.0 are vulnerable to Cross-site Scripting (XSS) via embedded links in whiteboard objects due to improper input sanitization.
- Record
CVE-2023-26140- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:P - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-v7v8-gjv7-ffmr
6.1
@excalidraw/excalidraw Cross-site Scripting vulnerability
Impact
XSS vulnerability due to improperly sanitizing URLs of links that can be attached on canvas elements. This affects users of the npm package @excalidraw/excalidraw provided it was deployed in environments where untrusted user input in drawings that are then shared with third parties is a concern. If you only hosted the editor in trusted environments, or sharing didn't take place, the impact is minimized.
Patches
Patch is available on version 0.15.3 and up (stable), or latest @excalidraw/excalidraw@next (unstable releases).
Workarounds
No workaround without upgrading unless deployed in environments without untrusted user input.
References
https://security.snyk.io/vuln/SNYK-JS-EXCALIDRAWEXCALIDRAW-5841658 https://github.com/excalidraw/excalidraw/pull/6728
- Record
GHSA-v7v8-gjv7-ffmr- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@excalidraw/excalidrawnpm |
before 0.15.3 | 0.15.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-26140 is a medium vulnerability (CVSS 6.1) in Excalidraw, published August 16, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 46th percentile. Fixed in @excalidraw/excalidraw 0.15.3.
References
security.snyk.io/vuln/SNYK-JS-EXCALIDRAWEXCALIDRAW-5841658
github.com/excalidraw/excalidraw/pull/6728
github.com/excalidraw/excalidraw/commit/b33fa6d6f64d27adc3a47b25c0aa55711740d0af
github.com/excalidraw/excalidraw/security/advisories/GHSA-v7v8-gjv7-ffmr
nvd.nist.gov/vuln/detail/CVE-2023-26140
github.com/advisories/GHSA-v7v8-gjv7-ffmr
github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26140.json
github.com/excalidraw/excalidraw