CVE-2023-26144
graphql Uncontrolled Resource Consumption vulnerability
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.3
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
- Record
CVE-2023-26144- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2023-2482
5.3
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
- Record
EUVD-2023-2482- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9pv7-vfvm-6vr7
5.3
graphql Uncontrolled Resource Consumption vulnerability
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.
Note: It was not proven that this vulnerability can crash the process.
- Record
GHSA-9pv7-vfvm-6vr7- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
5.3
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
- Record
CVE-2023-26144- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-400
- Updated
- 2026-11-02
OSV
5.3
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
- Record
CVE-2023-26144- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-26144
5.3
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
- Record
DEBIAN-CVE-2023-26144- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVGHSA-9pv7-vfvm-6vr7
5.3
graphql Uncontrolled Resource Consumption vulnerability
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.
Note: It was not proven that this vulnerability can crash the process.
- Record
GHSA-9pv7-vfvm-6vr7- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-26144
5.3
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
- Record
UBUNTU-CVE-2023-26144- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2023-26144 No score
CVE-2023-26144 in graphql - Patched by Root
Root has patched CVE-2023-26144 in the graphql package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2023-26144- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
graphqlnpm |
16.3.0 up to 16.8.1 | 16.8.1 |
node-graphqlDebian:12 |
All versions, plus listed versions 16.6.0-216.8.1-116.8.1-216.8.1-316.8.1-416.8.1-516.8.1-616.8.1-7 |
None known |
node-graphqlDebian:13 |
before 16.8.1-1 | 16.8.1-1 |
node-graphqlDebian:14 |
before 16.8.1-1 | 16.8.1-1 |
graphqlRoot:npm |
before 16.6.0-aikido.1 | 16.6.0-aikido.1 |
@rootio/graphqlRoot:npm |
before 16.6.0-root.io.1 | 16.6.0-root.io.1 |
node-graphqlUbuntu:22.04:LTS |
All versions, plus listed versions 15.5.0-115.5.0-2 |
None known |
node-graphqlUbuntu:24.04:LTS |
All versions, plus listed versions 16.6.0-216.8.1-116.8.1-2 |
None known |
node-graphqlUbuntu:25.10 |
All versions, plus listed versions 16.8.1-2 |
None known |
node-graphqlUbuntu:26.10 |
All versions, plus listed versions 16.8.1-316.8.1-416.8.1-5 |
None known |
node-graphqlUbuntu:26.04:LTS |
All versions, plus listed versions 16.8.1-216.8.1-3 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | tadhglewis/apollo-koa-minimal | 2023-08-16 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-26144 is a medium vulnerability (CVSS 5.3) in @tinacms Graphql, published September 20, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.45%, the 73rd percentile. Fixed in graphql 16.8.1.
References
security.snyk.io/vuln/SNYK-JS-GRAPHQL-5905181
github.com/graphql/graphql-js/pull/3972
github.com/graphql/graphql-js/issues/3955
github.com/graphql/graphql-js/commit/f94b511386c7e47bd0380dcd56553dc063320226
github.com/graphql/graphql-js/releases/tag/v16.8.1
nvd.nist.gov/vuln/detail/CVE-2023-26144
Show 7 moreShow less
github.com/graphql/graphql-js/commit/8f4c64eb6a7112a929ffeef00caa67529b3f2fcf
github.com/advisories/GHSA-9pv7-vfvm-6vr7
github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26144.json
security-tracker.debian.org/tracker/CVE-2023-26144
github.com/graphql/graphql-js
ubuntu.com/security/CVE-2023-26144
cve.org/CVERecord?id=CVE-2023-26144