Every CVE Search/ Get API key

CVE-2023-26150

asyncua Improper Authentication vulnerability

6.5 MediumFix available

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication. Note: This issue is a result of missing checks for services that require an active session.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.52%Up 0.5 points since Oct 3, 2023
90%50%10%1%

What each source reports

CVE List Score used 6.5

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication. Note: This issue is a result of missing checks for services that require an active session.

Record
CVE-2023-26150
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:P
Weakness
CWE-287
Updated
2026-11-02
EUVDEUVD-2023-0047 6.5

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication. Note: This issue is a result of missing checks for services that require an active session.

Record
EUVD-2023-0047
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:P
Updated
2026-11-03
GitHub AdvisoriesGHSA-2894-qcqf-g23g 7.5

asyncua Improper Authentication vulnerability

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication.

Note:

This issue is a result of missing checks for services that require an active session.

Record
GHSA-2894-qcqf-g23g
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-287
Updated
2026-11-02
NVD 6.5

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication. Note: This issue is a result of missing checks for services that require an active session.

Record
CVE-2023-26150
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-287
Updated
2026-11-02
OSV 6.5

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication. Note: This issue is a result of missing checks for services that require an active session.

Record
CVE-2023-26150
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:P
Weakness
CWE-287
Updated
2026-11-02
OSVGHSA-2894-qcqf-g23g 7.5

asyncua Improper Authentication vulnerability

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication.

Note:

This issue is a result of missing checks for services that require an active session.

Record
GHSA-2894-qcqf-g23g
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-287
Updated
2026-11-02
OSVPYSEC-2023-189 7.5

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication. Note: This issue is a result of missing checks for services that require an active session.

Record
PYSEC-2023-189
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2023-26150 6.5

Versions of the package asyncua before 0.9.96 are vulnerable to Improper Authentication such that it is possible to access Address Space without encryption and authentication. Note: This issue is a result of missing checks for services that require an active session.

Record
UBUNTU-CVE-2023-26150
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
asyncua
PyPI
before 0.9.96
0.9.96
asyncua
PyPI
before 0.9.96, plus listed versions
0.5.00.5.10.6.00.6.10.8.0
Show 21 moreShow less
0.8.10.8.20.8.30.8.40.9.00.9.10.9.100.9.110.9.120.9.140.9.20.9.30.9.60.9.80.9.90.9.900.9.910.9.920.9.930.9.940.9.95
0.9.96
asyncua
PyPI
before 0.9.96, plus listed versions
0.5.00.5.10.6.00.6.10.8.0
Show 45 moreShow less
0.8.10.8.20.8.30.8.40.9.00.9.10.9.100.9.110.9.120.9.140.9.20.9.30.9.60.9.80.9.90.9.900.9.910.9.920.9.930.9.940.9.95v0.9.95v0.9.94v0.9.93v0.9.92v0.9.91v0.9.90v0.9.12v0.9.11v0.9.10v0.9.80.9.70.9.40.90.40.90.30.90.20.90.10.90.00.10.170.10.150.10.140.10.120.10.110.10.90.10.8
0.9.96
python-opcua
Ubuntu:18.04:LTS
All versions, plus listed versions
0.90.3-1
None known
python-opcua
Ubuntu:20.04:LTS
All versions, plus listed versions
0.98.6-30.98.6-3ubuntu10.98.9-1
None known
python-opcua
Ubuntu:22.04:LTS
All versions, plus listed versions
0.98.11-10.98.11-1ubuntu1
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-26150 is a medium vulnerability (CVSS 6.5) in Freeopcua Opcua-asyncio, published October 3, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in asyncua 0.9.96.

References

Show 8 moreShow less
This page doesn't list everything

Left out here: 14 versions. The JSON record has them.

MoveEnter Open