CVE-2023-26157
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due...
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section->num_pages in decode_r2007.c.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
5.5
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section->num_pages in decode_r2007.c.
- Record
CVE-2023-26157- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:P - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2023-29984
5.5
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section->num_pages in decode_r2007.c.
- Record
EUVD-2023-29984- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:P - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5rxp-9658-h93v
5.5
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due...
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section->num_pages in decode_r2007.c.
- Record
GHSA-5rxp-9658-h93v- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-125, CWE-400
- Updated
- 2026-11-02
NVD
5.5
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section->num_pages in decode_r2007.c.
- Record
CVE-2023-26157- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400, CWE-125
- Updated
- 2026-11-02
OSV
5.5
Versions of the package libredwg before 0.12.5.6384 are vulnerable to Denial of Service (DoS) due to an out-of-bounds read involving section->num_pages in decode_r2007.c.
- Record
CVE-2023-26157- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:P - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:0147-1 No score
Security update for libredwg
This update for libredwg fixes the following issues:
Update to tag 0.12.5.6924:
- CVE-2023-26157: Fixed out-of-bound read involving section->num_pages in decode_r2007.c (boo#1218473)
- Record
openSUSE-SU-2024:0147-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13544-1 No score
libredwg-devel-0.12.5.6924-1.1 on GA media
These are all security issues fixed in the libredwg-devel-0.12.5.6924-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13544-1- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-26157 is a medium vulnerability (CVSS 5.5) in Gnu Libredwg, published January 2, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in libredwg 0.12.5.6924-bp155.3.6.1.
References
security.snyk.io/vuln/SNYK-UNMANAGED-LIBREDWG-6070730
github.com/LibreDWG/libredwg/commit/c8cf03ce4c2315b146caf582ea061c0460193bcc
github.com/LibreDWG/libredwg/issues/850
nvd.nist.gov/vuln/detail/CVE-2023-26157
github.com/advisories/GHSA-5rxp-9658-h93v
github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26157.json
lists.opensuse.org/archives/list/[email protected]/thread/WJZKASYCXFRWLMBF4XUIYV5ZN2WMSZYO
bugzilla.suse.com/1218473
suse.com/security/cve/CVE-2023-26157