Every CVE Search/ Get API key

CVE-2023-26302

markdown-it-py CLI crash on invalid UTF-8 characters

3.3 LowFix available

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.22%Down 0.7 points since Feb 23, 2023
90%50%10%1%

What each source reports

CVE List Score used 3.3

markdown-it-py CLI crash on invalid UTF-8 characters

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
CVE-2023-26302
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-173, CWE-173
Updated
2026-11-02
EUVDEUVD-2023-0130 3.3

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
EUVD-2023-0130
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-jrwr-5x3p-hvc3 7.1

markdown-it-py Denial of Service vulnerability in the command line interface

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
GHSA-jrwr-5x3p-hvc3
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-173
Updated
2026-11-02
NVD 3.3

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
CVE-2023-26302
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-173
Updated
2026-11-02
OSV 3.3

markdown-it-py CLI crash on invalid UTF-8 characters

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
CVE-2023-26302
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-173
Updated
2026-11-02
OSVDEBIAN-CVE-2023-26302 5.5

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
DEBIAN-CVE-2023-26302
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-jrwr-5x3p-hvc3 7.1

markdown-it-py Denial of Service vulnerability in the command line interface

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
GHSA-jrwr-5x3p-hvc3
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-173
Updated
2026-11-02
OSVROOT-APP-PYPI-CVE-2023-26302 5.5

CVE-2023-26302 in rootio-markdown_it_py - Patched by Root

Root has patched CVE-2023-26302 in the rootio-markdown_it_py package for Root:PyPI. Multiple fixed versions available.

Record
ROOT-APP-PYPI-CVE-2023-26302
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-26302 3.3

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
UBUNTU-CVE-2023-26302
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVPYSEC-2023-23 No score

Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.

Record
PYSEC-2023-23
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
markdown-it-py
PyPI
before 2.2.0
2.2.0
markdown-it-py
Debian:12
before 2.1.0-5
2.1.0-5
markdown-it-py
Debian:13
before 2.1.0-5
2.1.0-5
markdown-it-py
Debian:14
before 2.1.0-5
2.1.0-5
markdown-it-py
PyPI
before 2.2.0, plus listed versions
0.1.00.1.10.2.00.2.10.2.2
Show 35 moreShow less
0.2.30.3.00.3.10.3.20.3.30.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.5.10.5.20.5.30.5.40.5.50.5.60.5.70.5.80.6.00.6.10.6.21.0.01.0.0b11.0.0b21.0.0b31.1.02.0.02.0.12.1.0
2.2.0
markdown-it-py
PyPI
before 2.2.0, plus listed versions
0.1.00.1.10.2.00.2.10.2.2
Show 45 moreShow less
0.2.30.3.00.3.10.3.20.3.30.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.5.10.5.20.5.30.5.40.5.50.5.60.5.70.5.80.6.00.6.10.6.21.0.01.0.0b11.0.0b21.0.0b31.1.02.0.02.0.12.1.0v2.1.0v2.0.1v2.0.0v1.1.0v1.0.0v1.0.0b3v1.0.0b2v1.0.0b1v0.6.2v0.6.1
2.2.0
rootio-markdown_it_py
Root:PyPI
before 2.1.0+root.io.2
2.1.0+root.io.22.1.0+root.io.32.1.0+root.io.42.1.0+root.io.5
markdown_it_py
Root:PyPI
before 2.1.0+aikido.5
2.1.0+aikido.5
markdown-it-py
Ubuntu:22.04:LTS
All versions, plus listed versions
1.1.0-11.1.0-2
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-26302 is a low vulnerability (CVSS 3.3) in Executable Books Markdown-it-py, published February 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.22%, the 13th percentile. Fixed in markdown-it-py 2.2.0.

References

Show 6 moreShow less
This page doesn't list everything

Left out here: 34 versions. The JSON record has them.

MoveEnter Open