CVE-2023-26303
markdown-it-py crash on null assertions
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
3.3
markdown-it-py crash on null assertions
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
CVE-2023-26303- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-173, CWE-173
- Updated
- 2026-11-02
EUVDEUVD-2023-0131
3.3
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
EUVD-2023-0131- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-vrjv-mxr7-vjf8
7.1
markdown-it-py Denial of Service vulnerability
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
GHSA-vrjv-mxr7-vjf8- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-173
- Updated
- 2026-11-02
NVD
3.3
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
CVE-2023-26303- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-173
- Updated
- 2026-11-02
OSV
3.3
markdown-it-py crash on null assertions
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
CVE-2023-26303- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-173
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-26303
5.5
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
DEBIAN-CVE-2023-26303- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 6 moreShow less
OSVGHSA-vrjv-mxr7-vjf8
7.1
markdown-it-py Denial of Service vulnerability
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
GHSA-vrjv-mxr7-vjf8- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-173
- Updated
- 2026-11-02
OSVROOT-APP-PYPI-CVE-2023-26303
5.5
CVE-2023-26303 in rootio-markdown_it_py - Patched by Root
Root has patched CVE-2023-26303 in the rootio-markdown_it_py package for Root:PyPI. Multiple fixed versions available.
- Record
ROOT-APP-PYPI-CVE-2023-26303- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-26303
3.3
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
UBUNTU-CVE-2023-26303- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:12772-1 No score
python310-markdown-it-py-2.2.0-1.1 on GA media
These are all security issues fixed in the python310-markdown-it-py-2.2.0-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:12772-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:12015-1 No score
python313-markdown-it-py-4.2.0-1.2 on GA media
These are all security issues fixed in the python313-markdown-it-py-4.2.0-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:12015-1- Updated
- 2026-11-02
OSVPYSEC-2023-24 No score
Denial of service could be caused to markdown-it-py, before v2.2.0, if an attacker was allowed to force null assertions with specially crafted input.
- Record
PYSEC-2023-24- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
markdown-it-pyPyPI |
before 2.2.0 | 2.2.0 |
markdown-it-pyDebian:12 |
before 2.1.0-5 | 2.1.0-5 |
markdown-it-pyDebian:13 |
before 2.1.0-5 | 2.1.0-5 |
markdown-it-pyDebian:14 |
before 2.1.0-5 | 2.1.0-5 |
markdown-it-pyPyPI |
before 2.2.0, plus listed versions 0.1.00.1.10.2.00.2.10.2.2 Show 35 moreShow less0.2.30.3.00.3.10.3.20.3.30.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.5.10.5.20.5.30.5.40.5.50.5.60.5.70.5.80.6.00.6.10.6.21.0.01.0.0b11.0.0b21.0.0b31.1.02.0.02.0.12.1.0 |
2.2.0 |
markdown-it-pyPyPI |
before 2.2.0, plus listed versions 0.1.00.1.10.2.00.2.10.2.2 Show 45 moreShow less0.2.30.3.00.3.10.3.20.3.30.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.5.10.5.20.5.30.5.40.5.50.5.60.5.70.5.80.6.00.6.10.6.21.0.01.0.0b11.0.0b21.0.0b31.1.02.0.02.0.12.1.0v2.1.0v2.0.1v2.0.0v1.1.0v1.0.0v1.0.0b3v1.0.0b2v1.0.0b1v0.6.2v0.6.1 |
2.2.0 |
rootio-markdown_it_pyRoot:PyPI |
before 2.1.0+root.io.1 | 2.1.0+root.io.12.1.0+root.io.22.1.0+root.io.32.1.0+root.io.42.1.0+root.io.5 |
markdown_it_pyRoot:PyPI |
before 2.1.0+aikido.5 | 2.1.0+aikido.5 |
markdown-it-pyUbuntu:22.04:LTS |
All versions, plus listed versions 1.1.0-11.1.0-2 |
None known |
python-markdown-it-pyopenSUSE:Tumbleweed |
before 2.2.0-1.1 | 2.2.0-1.1 |
python-markdown-it-pyopenSUSE:Tumbleweed |
before 4.2.0-1.2 | 4.2.0-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-26303 is a low vulnerability (CVSS 3.3) in Executable Books Markdown-it-py, published February 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.22%, the 13th percentile. Fixed in markdown-it-py 2.2.0.
References
github.com/executablebooks/markdown-it-py/commit/ae03c6107dfa18e648f6fdd1280f5b89092d5d49
nvd.nist.gov/vuln/detail/CVE-2023-26303
github.com/executablebooks/markdown-it-py/pull/246
github.com/executablebooks/markdown-it-py/commit/53ca3e9c2b9e9b295f6abf7f4ad2730a9b70f68c
github.com/pypa/advisory-database/tree/main/vulns/markdown-it-py/PYSEC-2023-24.yaml
github.com/advisories/GHSA-vrjv-mxr7-vjf8
Show 7 moreShow less
github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26303.json
github.com/executablebooks/markdown-it-py
github.com/executablebooks/markdown-it-py/releases
security-tracker.debian.org/tracker/CVE-2023-26303
ubuntu.com/security/CVE-2023-26303
cve.org/CVERecord?id=CVE-2023-26303
suse.com/security/cve/CVE-2023-26303
Left out here: 34 versions. The JSON record has them.