CVE-2023-26314
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the...
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.
- Record
CVE-2023-26314- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
CVE List
8.8
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.
- Record
CVE-2023-26314- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
EUVDEUVD-2023-30135
8.8
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.
- Record
EUVD-2023-30135- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-796j-2mh8-qff6
8.8
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the...
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.
- Record
GHSA-796j-2mh8-qff6- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.
- Record
CVE-2023-26314- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-26314
8.8
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.
- Record
DEBIAN-CVE-2023-26314- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-26314
8.8
The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution because the application/x-ms-dos-executable MIME type is associated with an un-sandboxed Mono CLR interpreter.
- Record
UBUNTU-CVE-2023-26314- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
monoDebian:12 |
before 6.8.0.105+dfsg-3.3 | 6.8.0.105+dfsg-3.3 |
monoDebian:13 |
before 6.8.0.105+dfsg-3.3 | 6.8.0.105+dfsg-3.3 |
monoDebian:14 |
before 6.8.0.105+dfsg-3.3 | 6.8.0.105+dfsg-3.3 |
monoDebian:10 |
before 5.18.0.240+dfsg-3+deb10u1, plus listed versions 5.18.0.240+dfsg-3 |
5.18.0.240+dfsg-3+deb10u1 |
monoUbuntu:14.04:LTS |
All versions, plus listed versions 2.10.8.1-5ubuntu23.2.3+dfsg-53.2.3+dfsg-7ubuntu13.2.8+dfsg-4ubuntu13.2.8+dfsg-4ubuntu1.1 |
None known |
monoUbuntu:16.04:LTS |
All versions, plus listed versions 3.2.8+dfsg-4ubuntu44.2.1.102+dfsg2-5ubuntu14.2.1.102+dfsg2-7ubuntu4 |
None known |
monoUbuntu:18.04:LTS |
All versions, plus listed versions 4.6.2.7+dfsg-1ubuntu1 |
None known |
monoUbuntu:20.04:LTS |
All versions, plus listed versions 5.18.0.240+dfsg-36.8.0.105+dfsg-16.8.0.105+dfsg-2 |
None known |
monoUbuntu:22.04:LTS |
All versions, plus listed versions 6.8.0.105+dfsg-3.2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-26314 is a high vulnerability (CVSS 8.8) in Mono-project Mono, published February 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.97%, the 62nd percentile. Fixed in mono 6.8.0.105+dfsg-3.3.