Every CVE Search/ Get API key

CVE-2023-27985

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections...

7.8 HighFix available

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.08%Up 1.0 points since Mar 9, 2023
90%50%10%1%

What each source reports

NVD Score used 7.8

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Record
CVE-2023-27985
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
CVE List 7.8

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Record
CVE-2023-27985
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
EUVDEUVD-2023-31711 7.8

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Record
EUVD-2023-31711
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-f5fq-43fc-vgcr 9.8

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections...

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification.

Record
GHSA-f5fq-43fc-vgcr
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
OSVALPINE-CVE-2023-27985 7.8

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Record
ALPINE-CVE-2023-27985
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSVAZL-25581 7.8

CVE-2023-27985 affecting package emacs for versions less than 28.2-4

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Record
AZL-25581
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSV 7.8

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Record
CVE-2023-27985
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-27985 7.8

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Record
DEBIAN-CVE-2023-27985
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-27985 7.8

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90

Record
UBUNTU-CVE-2023-27985
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:12777-1 No score

emacs-28.2-3.1 on GA media

These are all security issues fixed in the emacs-28.2-3.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12777-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
emacs
Alpine:v3.17
28.1 up to 28.2-r2
28.2-r2
emacs
Alpine:v3.18
28.1 up to 28.2-r5
28.2-r5
emacs
Alpine:v3.19
28.1 up to 28.2-r5
28.2-r5
emacs
Alpine:v3.20
28.1 up to 28.2-r5
28.2-r5
emacs
Alpine:v3.21
28.1 up to 28.2-r5
28.2-r5
emacs
Alpine:v3.22
28.1 up to 28.2-r5
28.2-r5
emacs
Alpine:v3.23
28.1 up to 28.2-r5
28.2-r5
emacs
Alpine:v3.24
28.1 up to 28.2-r5
28.2-r5
emacs
Azure Linux:2
before 28.2-4
28.2-4
emacs
Debian:12
before 1:28.2+1-13
1:28.2+1-13
Show 19 moreShow less
Affected packages
PackageAffectedFixed
emacs
Debian:13
before 1:28.2+1-13
1:28.2+1-13
emacs
Debian:14
before 1:28.2+1-13
1:28.2+1-13
xemacs21
Ubuntu:16.04:LTS
All versions, plus listed versions
21.4.22-4ubuntu321.4.22-14ubuntu1
None known
xemacs21-packages
Ubuntu:16.04:LTS
All versions, plus listed versions
2009.02.17.dfsg.2-2
None known
xemacs21
Ubuntu:18.04:LTS
All versions, plus listed versions
21.4.24-4ubuntu121.4.24-5ubuntu1
None known
xemacs21-packages
Ubuntu:18.04:LTS
All versions, plus listed versions
2009.02.17.dfsg.2-4
None known
xemacs21
Ubuntu:20.04:LTS
All versions, plus listed versions
21.4.24-8build121.4.24-9
None known
xemacs21-packages
Ubuntu:20.04:LTS
All versions, plus listed versions
2009.02.17.dfsg.2-42009.02.17.dfsg.2-5
None known
xemacs21
Ubuntu:22.04:LTS
All versions, plus listed versions
21.4.24-9ubuntu2
None known
xemacs21-packages
Ubuntu:22.04:LTS
All versions, plus listed versions
2009.02.17.dfsg.2-5
None known
xemacs21
Ubuntu:24.04:LTS
All versions, plus listed versions
21.4.24-1221.4.24-12build221.4.24-12build3
None known
xemacs21-packages
Ubuntu:24.04:LTS
All versions, plus listed versions
2009.02.17.dfsg.3-22009.02.17.dfsg.3-3
None known
xemacs21
Ubuntu:25.10
All versions, plus listed versions
21.4.24-12build3
None known
xemacs21-packages
Ubuntu:25.10
All versions, plus listed versions
2009.02.17.dfsg.3-3
None known
xemacs21
Ubuntu:26.10
All versions, plus listed versions
21.4.24-12build3
None known
xemacs21-packages
Ubuntu:26.10
All versions, plus listed versions
2009.02.17.dfsg.3-3build1
None known
xemacs21
Ubuntu:26.04:LTS
All versions, plus listed versions
21.4.24-12build3
None known
xemacs21-packages
Ubuntu:26.04:LTS
All versions, plus listed versions
2009.02.17.dfsg.3-32009.02.17.dfsg.3-3build1
None known
emacs
openSUSE:Tumbleweed
before 28.2-3.1
28.2-3.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-27985 is a high vulnerability (CVSS 7.8) in Gnu Emacs, published March 9, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in emacs 28.2-r2.

References

Show 7 moreShow less
MoveEnter Open